HELP winscp Permission denied. Error code: 3 Error message from server: Permission denied

Help
this is the error I get Im using winscp
I went into preference & disabled the endurance as directed
I am still not able to add info to my rpt.conf

somehow I feel the older system was so much easier

HELP

I don’t know what WinSCP “endurance” setting is for but I wouldn’t expect it to help permission problems.

When is the error occurring, at logon or when you attempt to edit rpt.conf?

when trying to edit and or modify my conf folders as I need to
to setup the node to be a dmr bridge

it wont allow me to modify any folders etc

Sounds like WinSCP is connecting to the node fine. So you don’t have a port or password issue.

If you are logging in with username repeater you do not have permission to edit any files in /etc/asterisk. You need to login with username root but the root user is not allowed to ssh by default. It is possible to allow root ssh but I’m not sure how folks using WinSCP handle that.

Would any WinSCP users like to shed some light on this?

this should be in the wiki

before connecting to the site on the site list of winscp make sure the protocol used to connect to the node is SCP

If it is not scp click on edit and change it.

login

Then click on advance
adv

and choose scp/shell on the left pan. and in the shell menu select sudo su -

scp shell

click OK
save the configuration and reconnect. you will be able to edit every file on the node with winscp

1 Like

I dont know in the new asl software, setting up the old crompton images root was the norm

so odd this has been changed

Sir, thanks I wil try to access the node now that way

sadly that doesnt work either

I have my root password set to the same as the repeater password though it states access denied

log in with repeater

dont try to log with root from ssh

Le mer. 26 févr. 2020 à 15:20, Mike P via AllStarLink Discussion Groups noreply@community.allstarlink.org a écrit :

···


Mike_P

    February 26

Sir, thanks I wil try to access the node now that way

sadly that doesnt work either

I have my root password set to the same as the repeater password though it states access denied


Visit Topic or reply to this email to respond.


In Reply To


Pierre_Martel

    February 23

this should be in the wiki before connecting to the site on the site list of winscp make sure the protocol used to connect to the node is SCP If it is not scp click on edit and change it. [login] Then click on advance [adv] and choose scp/shell on the left pan. and in the shell menu select sud…


Visit Topic or reply to this email to respond.

You are receiving this because you enabled mailing list mode.

To unsubscribe from these emails, click here.

ok thanks

than how do I get root access

I assume root is like admin privileges

repeater is like a user

Ill go try that now, thanks

wow
THANKS THAT IS WORKING
now maybe I can finish its etup

the setup I gave you is the same thing as loging with a simple user and escalate the rights of the user to super user with sudo ou su.
SO you keep a safe config on the node that root cant connect on ssh but can still do as a root user with the normal user login.

Le mer. 26 févr. 2020 à 19:59, Mike P via AllStarLink Discussion Groups noreply@community.allstarlink.org a écrit :

···


Mike_P

    February 27

wow

THANKS THAT IS WORKING

now maybe I can finish its etup


Visit Topic or reply to this email to respond.


In Reply To


Pierre_Martel

    February 26

log in with repeater dont try to log with root from ssh Le mer. 26 févr. 2020 à 15:20, Mike P via AllStarLink Discussion Groups noreply@community.allstarlink.org a écrit : ··· (click for more details)


Visit Topic or reply to this email to respond.

You are receiving this because you enabled mailing list mode.

To unsubscribe from these emails, click here.

Yes, thanks
I got some help on the main forum
I have it almost complete
last step is to see if I can add a node radio to the bridge
I cant seem to access simpleusb-tune-menu under sudo -s though

SCP is a PITA!

I don’t use it for that reason.

nano is much better, and does not require special program to work.

So after you ssh into your ASL box,
sudo nano /etc/asterisk/rpt.conf

sudo works usually has a 15 minutes TOT after last use of it.

thanks for the new info