GM300 Won't Transmit RIM-Maxtrac

Trying to help another ham get up and running but can’t get the GM300 to transmit.
The xmit LED on the RIM-Maxtrac board doesn’t come on. I have toggled PTT mode.
Using View mode, I can key my test HT and PTT status changes from clear to keyed.
Going into #4, audio transmit mode, still no transmit, but when using a handmic on GM300, keying it will turn on the xmit LED on the RIM interface and the 1KHz tone is transmitted out the GM300.
What am I overlooking?

You should check your COS to make sure that it is operating correctly, and also check which duplex setting you have in usbradio or simpleusb.

If the node is configured for half-duplex, and receiving COS, it will not transmit. An easy way to check the COS is to go to radio-tune-menu or simpleusb-tune-menu and look at received Audio level. If you see a > indicator, COS is active, and the node thinks the radio is receiving a valid signal.

If the COS indication does not match the state of the radio, for example the node thinks it should be receiving when the radio is not, you may need to adjust your cos setting from inverted to non-inverted etc. It’s really hard to advise without knowing more about your setup.

Another easy thing to try would be to change cos to “no” for the purpose of testing push to talk.

73, good luck. I’ll be around at times today if you want to test.

Allstar 2210
EchoLink K0KN-L
HH 12441

Thanks Kyle. It is set for full-duplex. But if from the View menu, if I see PTT change from CLEAR to KEYED when it receives a signal from my HT, shouldn’t that cause the RIM- Maxtrac interface PTT LED to come on? I have tried to toggle the PTT Mode and no change, still no transmit.

Upon further research, it appears the problem is with the RIM-Maxtrac USB sound chip GPIO3 not being addressed by the RPi. I can find Soundmodem for windows but not the RPi. A ptt.dll in this software apparently will solve my problem.
Any assistance available?

I had the luxury of having a 2nd RIM LITE - (that worked properly) - rare as it is, there was a cold solder joint on the board - Joel took care of the board forth with and all is well. de nu5d

NU5D, was your RIM connected to a Raspberry Pi or Windows computer?
I’m not sure who Joel is? But I sent an email to Scott of Repeater Builder for assistance but haven’t heard back yet.

I have 5 or 6 Rim Lite and DRA-65 - some Dell 3020, some Pi3, - this and that. I don’t know where I got Joel - meant Scott Zimmerman- Repeater Builder - Had a problem - problem fixed and all is well. One easy way to do some testing on a Windows PC - Install Sound Modem - UZ7HO packet virtual TNC - works with Cm108 / 119 - you can receive - see a waterfall from the radio and tx and send test tones - easy tool for testing. de nu5d