Garbled RX with one node

I’m not understanding why voices are garbled/underwater when I listen to one node but all the other nodes I listen to are fine.

I’m running a node in the cloud on and I connect to it via DVSwitch on my Android smartphone.

The node I am having trouble receiving is 2462 (Puget Sound Repeater Group). For contrast, node 51018 (W6EK) comes in perfectly.

Why would one node be impossible to understand and the other sound absolutely perfect? Is it something in my node-in-the-cloud, in my DVSwitch configuration, or something I should report to the PSRG node admins?

Thanks much,

Tom KJ7T

A bit more info as I investigate. When I connect to 2462 through my ClearNode, there is a hint of the garbled sound. Volume is higher. When I connect to 2462 through my node on, there is a lot of garbled sound making it almost unintelligible. Volume is lower.

Other nodes seem fine when I connect through the ClearNode and the node. It’s just the 2462 node that is problematic.

I did connect to 2462 for a listen, but no traffic.

I suspect the issue is simply internet bandwidth for that path. The node may be at maximum ? OR some other issues between you and it for path. Could be a issue with the 2462 node itself.
Asterisk is not friendly to delay in the audio stream. A few dropped or untimely sequenced packets can really screw things up. And if the server is already tasked well, it could be the server itself, especially if there are more connects than it can support. Or even some combination of the above.

Just guessing. Don’t start adjusting anything till you know where the issue is.

This doesn’t sound like the problem is on your end.

On another subject, if you get different volume levels from a given node, in this case 2452, there is an unrelated problem on your end. Any number of Allstar nodes listing to the same source should sound exactly the same given you’re using the same radio to listed to both your ClearNode and your Vultr node.

You might want to run through the alignment procedure again to set the receive level the same from both of your nodes. What are you using for a radio connection to Vultr?

BTW, I don’t have one but I’m told ClearNodes are very nice. Also I use Vultr for some nodes and they work well too.

The volume difference may be a setting in DVSwitch. For the node, I connect to it via the DVSwitch app on my smartphone. That works fine as long as the internet connection is strong and stable.

For the ClearNode device (which is quite nice!), I connect by RF with a Yaesu HT or I use DVSwitch. Most of the time, I use DVSwitch.

I’m thinking it’s something in the node configuration. I updated the system yesterday, hoping that would resolve it, but it didn’t.

I would say the source of your issue is in the DVSwitch mobile app and or the settings of your node for/with it.
You did not mention that in the first instance as your description resembles a bad digital connection in your use of the term ‘garbled’…

Well, to me “bad digital” often means spotty or intermittent, because unlike analog, digital tends to be there or not there. In my case, it is a constant signal but the audio varies quickly and regularly, very fast, like someone speaking underwater with a layer of static. I don’t know if that description helps.

Yes, under water describes it well.
So, do you have dvswitch installed on your vultr server ?
Analog reflector ?
DVSwitch Server ?
While I ask/say that, I still think it is the settings in your app.
The only reference you have is from the DVS app.

For a test, why not install iaxrpt on a PC and connect up to that node and make the connection that way.

You might mention if you have some other server with a node to test with (that is yours)

let me also ask you exactly how you are initiating this connection?

for instance, are you using a saved predial in the app
are you commanding the node(57945) with the command *32462 for the connection

(Didn’t see my emailed reply so posting it via web)

IAXRpt is a great recommendation. That took all of 10 minutes to configure and it worked on the third try. I’m getting great audio from my ClearNode to my local computer via a headset. Thank you.

I have a macro set up to send *32462 after connecting to node 57945. Usually, though, I “listen in” by sending *22462.

Just tested again with these results:

  • DVSwitch (smartphone) to my local ClearNode, then *22462 => gives clear audio
  • IAXRpt (PC) to my local ClearNode, then *22462 => gives clear audio
  • DVSwitch (smartphone) to cloud node, then *22462 => gives garbled audio

Based on this, I think the problem is with my cloud node.

Yes, I had one of my limited traffic nodes connected for a listen when you tested.
I did hear what you are speaking of, but it was my bedtime LOL.

Can you post your rpt.conf for 57945

perhaps your iax.conf as well, but mask the passwords in registration lines.

Copy of rpt.conf and cleaned iax.conf in Mega folder at 31.1 KB folder on MEGA

I’ll put a few adjustments you should try, in order, one at a time and test.
A simple ‘reload’ will do from a ‘asterisk CLI’

In iax.conf
; bindaddr = < change this
bindaddr = < to this, uncommented

type = user
context = allstar-sys
auth = rsa
inkeys = allstar
disallow = all
allow = ulaw
allow = gsm < add this

Finally, ‘move’ this to the bottom of the file in rpt.conf

; Note, if you are using automatic update for allstar link nodes,
; no allstar link nodes should be defined here. Only place a definition
; for your local nodes, and private (off of allstar link) nodes here.

57945 = radio@,NONE ; This must be changed to your node number
; and iax port number if not the default

#includeifexists custom/rpt.conf < But above this

Any one of these could be causing some issues, but having herd your issue, I am curious which it is.
But they do all need changing.

Made the changes and restarted asterisk. I’ll listen in tonight and see if the changes made a difference. I did just listen to nodes 43211 and 51018, clear audio on both. Fingers crossed.

Here’s a brief recording of the audio heard on node 2462 after making the changes you suggested. I am using DVSwitch on an Android phone to connect to my Vultr node, and from the Vultr node to 2462. I recorded audio from the phone using a voice recording app. The improvement over the previous “underwater” garbled sound is remarkable. Link: 714.3 KB file on MEGA