Failure code:(50) No authority found

I have just installed Allstarlink on a Pi Zero, i find the node is registered from Allstar Home page,i tried dialling to my node from an android phone using DvSwitch mobile application, i hear it dialing but i get an error (50) No authority found , i have forwarded my ports 4569 and also checked password , using iax-client as user name. I have tried to other nodes also same result, dont know where iam going wrong, any help would be highly appreciated. 73’s

I think you need to make your query with the support of DVSwitch
I remember seeing the issue on their board several times but did not read them.

You ‘might’ search for it there and find the issue and fix without a new query.
Using ‘No authority found’ for search. But as I remember it, it is a config issue.

1 Like

I don’t think a Pi Zero will run Allstar. Not sure what the issue with DVSwitch mobile is. Remember Allstar needs separate ports when the nodes are on the same LAN. Could that be what you are running into?

This is the section of the extended change log for DVSM V2.x

HamVoip and DVSwitch Mobile

    HV, being a fork of Allstar, has diverged over time from the base code.  

Several of these changes affect how clients connect and get metadata from a HV node.
Below are notes on being successful with DVSM and HV.


        HV by default has enabled calltoken support.  

Calltokens are discussed here.
DVSM has enabled calltoken support by default so no additional action needs to be taken by the user. However, if you are using older versions of DVSM or other clients you may want to disable this option. In your iax.conf add this to your user section:

            Calltokenoptional =

            Requirecalltoken = no


        HV has disabled dialing by other connections / links by default.  

This means that a DVSM client connected to a HV node (in WT or NM) will not be able to command that node to connect / disconnect / COP to any other node.
To enable dialing add these lines to your rpt.conf in your node section:

            Propagate_dtmf = yes

            Remote_dtmf_allowed = 1


        HV has disabled link messages being broadcast by a node.  

This will cause DVSM to not be able to populate its connected node list on the Status tab of the app. Add this line to your node section in rpt.conf

           Phonesendlinks = 1

Steve N4IRS

Tks for reply Tim, iam running Dvswitch and Allstar combined img on a Pi Zero 2W,
able to run DVS without any issue using DVS Mobile app, when i run ALS it is says registered but when i connect after entering a node i get the error, tks anyway, will approach DVSwitch IO forum. Tks again