Error installing python3-pip for SkywarnPlus

I have installed SkywarnPlus on 1 repeater fine. On a second system, it will NOT install python3-pip correctly. I’ve tried a few fixes, but nothing works. Any help from linux gurus is appreciated.!

Repeaters are running Debian10 ’ Buster '.
Everything installed and working on my repeater fine.
On the club repeater,
python3 installed fine. When I try ’ apt install python3-pip ', I get this:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
python3-pip : Depends: python3-distutils but it is not installable
Recommends: python3-dev (>= 3.2) but it is not installable
Recommends: python3-setuptools but it is not installable
Recommends: python3-wheel but it is not installable
E: Unable to correct problems, you have held broken packages.

If I try to run SkywarnPlus, I get:
Traceback (most recent call last):
File “/usr/local/bin/SkywarnPlus/”, line 45, in
from dateutil import parser
ModuleNotFoundError: No module named ‘dateutil’

Have you found a solution?

I believe the issue there was the repositories were not compatible with deb 10/buster for the py3 dependencies.

But I could be wrong about that.

Newer repo and take chances or newer OS that draw from newer repos.
I have never had an issue with adjusting to newer repo temporarily to get the dependencies.
But problems could exist with that.
I have never tried it with this software.

I was not able to correct the issue, so I went to ’ Plan B '. I cloned the SD card from the working system, modified the contents for the second repeater, then drove up to the remote site and swapped out the SD card. Interesting that both repeaters were running the exact same Debian? Well, it is working now!

I believe my memory failed me a bit because I think issues I was thinking were with DEB9 and PY3

But there have been many head scratching errors fixed with a SD reload or new SD card.

Ya just don’t know till you try it. Sometimes the software used to write the card as well.