EchoLink error message when loading chan_echolink module

Setting up a new node for someone and he would like EchoLink to be enabled which I have not set up before. I enabled ‘load =>’ in modules.conf, confirmed ports 5198-5200 are open in iptables and are being forwarded to the node in my router settings, and restarted everything, but I when I try to connect nothing happens, and I see no messages or errors in the syslog or Asterisk console. The only thing I do see in the console is that if I run “module load chan_echolink” it returns: ERROR[8186]: chan_echolink.c:3304 store_config: One of the Echolink servers missing

But the server[n] lines in echolink.conf have the default settings, ie.:

server1 =
server2 =
server3 =

Does anyone have ideas how to debug this? Thanks

First, it is not 5198-5200
5198 5199 udp
5200 tcp

Know that if you are trying to connect to the local machine and using the same wi-fi,
it will not work for echolink will only allow one registration per wan IP.
So, turn the wifi off on that phone so it does not do this without you knowing.

Hi MIke, I had reviewed the link you posted and did everything exactly as suggest there. And it is ports 5198-5200, exactly as you listed. Those are all being properly forwarded, exactly as mentioned in the link. However the error message seems to indicate the chan_echolink module is not starting in the first place so I don’t think the issue has anything to do with the ports. Thanks

Problem Solved!

I noticed in some echolink setup pages online that 4 servers are used in the PC app, whereas ASL echolink.conf only has 3 defines and says “; Max 3 servers” above that. So as an experiment I tried using the same settings as shown for the PC app and it now works great. I was able to connect right away to the EchoLink Echotest server and everything works perfectly.

Updated server lines in echolink.conf FYI:
; Max 3 servers
server1 =
server2 =
server3 =
server4 =

So looks like this is an issue in that the default echolink.conf file in the (latest from github, compiled from source) ASL 2.0 beta distribution is missing the server4 line.

Some errors can be deceiving.

But no other registrations can be active from your wan address or they will not register. Sometimes you get many strange effects. And those effects are the deception I am talking about.

And also know that often it takes a bit longer for a registration to be pushed to the EL DB than ASL.

is it loaded?
module show like chan_echolink

You might need to scan the log to see if it is actually running after the load.

Perhaps also look at the .conf file with a ‘all text code viewer’ and be sure no hidden corruptive characters are in there.

If you don’t find it, post the exact error

Hi Mike, issue has been solved. See my message before yours above. Thanks

Well, as far as I know, it will only rotate 3 servers.
It goes tot he next on failure.
Sometimes, they go down and it is plausible that 3 that you had listed to use go down.

Perhaps there has been a change I was not aware of.

But at least you can see how weird a registration issue can give the appearance of something else.

The 3 I use are

you set 5198-5200 BOTH in order to connect. if you set it they way they want you to it will not connect correctly. I have been there and done that.

ASL is only 3 servers. Hamvoip can use all 4. you are correct 5198-5200 Both(tcp/udp) need to be set in the router. especially for Hamvoip.

Echolink uses ports 5198 & 5199 UDP (native original)
TCP port 5200 was added later mainly for iphones and others that could not use the udp ports.

But if you want to open them all for both UDP & TCP it will work the same but you have the additional security risk to have open and unanswered TCP ports for hack. Personal choice I guess.

That is a echolink thing and security thing, no matter asl/hamvoip.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.