Duplex option for simplex node

I have a simplex node that listens to HF. The squelch is down so the COS is in play but always high. I want the full duplex nodes to be able to transmit the simplex HF node even though the cos is open on it.

Is there a configuration that allows this?

I think I follow your objective.

First, if you are set-up as a remote in rpt.conf, you might want to remove that note in the file…
29261 = radio@192.168.5.223:4569/29261,y ← remove y and replace NONE

(I believe this forces some duplex semantics when y)

Set the node up as full duplex as like a repeater.
duplex=2 (rpt.conf)

The next part is just a strong suggestion…
I would convert the physical node the HF Radio is set to as a private node, like 1850
It can have half duplex scheme if you like. You are not going to connect from outside the server to it but the other possible public (full duplex) node

If this is a agile remote (controlled tuning) put the command info in the full duplex node as well the serial port info etc. Use that node to control it from, and the private node (ie 1850) for a sound switch so to speak.

So when you no longer want to hear it, just disconnect the private node (1850) and gives you the ability to connect as monitor etc and have talk-over.

Telling the system it is a remote base limits the number of connects to the node to ‘1’.
Setting it up as a private node keeps outsiders from connecting directly to it and the control is in the full duplex node so you would know when it is being controlled from there. But it still takes the private node connection to hear/talk to it.

Hopefully I said this in a way you easily understand.

All my nodes have NONE in that field.

If you set duplex 2, when the radio receives a signal it wants to transmit, Full-duplex.

I just want the ability to transmit even if COS is high. So far i have not found a combo that does that.

The other issue with this is timing out the other nodes and the 3 minute limit (rules) for FM repeaters. I will need to come up with a better idea.

I have seen syllabic squelch so I may look into that as an option.

You can use vox for cor

Mike, Rx noise will keep vox open. He needs syllabic squelch like I use.

GeorgeC W2DB

1 Like

Right you are !
I’m still scratch’n my head on how I use to do it now… perhaps make a new hole…

Yeah, syllabic squelch or other technique that detects actual voice will be needed. I rolled my own around 15+ years ago that worked for VHF. It used a Michels Engineering DSP noise reduction unit to pick out voice (and as a bonus, clean up received signals), and a custom VOX to minimise false triggering from noise pulses. This worked superbly on VHF SSB. HF needed additional filtering between the DSP and VOX to minimise false triggering from grossly off frequency signals.

The squelch could detect signals near the readability threshold, and taking the audio from the DSP meant signals into the system (I was using Echolink at the time) was clean.

I implemented the VOX part with hardware peak detectors and a custom programmed PIC. As this is the second time this topic has come up today in two totally unrelated places, I’ll put my source code up on GitHub when I get a chance. I’m pretty sure it’s already GPL2.0 licensed, I’ll have to check and if not add the GPL notice.

I built up a syllabic squelch board. Originally I used it in my FT857’s to make like Micom squelch. But it works great for remote base COS type signal. I’ve only done it as a temporary lash up till I can get the squelch board into a cabinet then I’ll have my remote base active. If you want info on the board/schematic let me know and I’ll send it to you.

The schematic I used was not from Micom. It is simple, 2 IC’s and other parts.
GeorgeC W2DB

I have been digging for a few years to find some of my old configs.
I did find one and it does not make sense to me now and may have been accidentally edited and no longer correct.

But the key it looks for me was duplex=0 in usbradio and carrierfrom=dsp
In rpt.conf, it was duplex=0 as well.

In some ways, it does make sense, but try this at your own risk.
I can’t see it hurting anything !
And remember, this was from a acid ver install in 2012.

[usb29261]
pp4=ptt

hdwtype=0
rxboost=0
txboost=1
rxctcssrelax=1
;txctcssdefault=100.0
rxctcssfreqs=no
txctcssfreqs=no
;rxctcssoverride=0

;carrierfrom=no
;carrierfrom=dsp
;carrierfrom=usb
;carrierfrom=usbinvert
;carrierfrom=ppinvert
carrierfrom=dsp

rxdemod=speaker
txprelim=yes
txlimonly=no
txtoctype=notone ; Transmit tone control type: no,phase,notone
; no - CTCSS tone encoding with no hang time
; phase - encode CTCSS and reverse phase
; AKA (“reverse burst”) before unkeying TX
; notone - encode CTCSS and stop sending tone before unkeying TX
; AKA (“chicken burst”)
txmixa=composite
txmixb=no
invertptt=0
duplex=0
rxondelay=0
rxnoisefiltype=0
eeprom=0

Let me know if you try it.

@n5zr Did you come up with a solution that worked for you?
Curious and if you did, would like you to share it to help others.
I am a bit delayed in restarting my efforts for a model testing set-up.