DTMF commands decoding but not processing?

Just got my node working and can see DTMF commands being heard on my simplex node in CLI but not processing.
Asterisk/Debian on a Dell laptop.

  1. Where do I need to enable them?
  2. Can I also connect with a command line?

Is there a macro defined in rpt.conf for each DTMF command being sent to o the node?


I had previously looked in that file and it’s like drinking from a firehose. I don’t know where to begin.
I think because my system is a laptop it’s the full blown operating system so the repeater.config file is huge!
Has anyone enabled the macros for tones on one of these?

DTMF decoding is enable by default, no macros needed. What DFTM command are you trying? Where did you download AllStar?

Here, CLI show decoding but not executing. Using codes in repeater conf file.

Seems to be working now, hear a double beep after I dtmf a connection but it’s says connection failed. :thinking:
When I posted this I can see the decode but nothing.
Will keep experimenting.

Try a 70 That will tell you it’s decoding. If you are unable to connect to another node it may be that your node is not registering with AllStarLink You can test that from the CLI with iax2 show registry this is what a registered node looks like:
CLI> iax2 show registry
Host dnsmgr Username Perceived Refresh State Y 2153 180 Registered

The State column shows that 2153 is registered.

Your other issue may be the node list. Try systemctl restart updatenodelist

Steve N4IRS

run it as root (sudo -s)

I was able to run it in asl-menu.
I’m connected to another node, and noticed earlier when I used *3node the double beep was heard and it was working. So maybe you are correct with updating the node list?
Interesting that the 513920 I tried was connection failed and he just called me and commented he had the same problem with other nodes. I suggested he try updating his list also.
Thanks Steve.
I eventually might try dvswitch :flushed:

So this evening I found my node disconnected from another node.
CLI isn’t responding to dtmf through my RF link. CLI functions with EchoLink and inputting commands rpt fun 29978 *3node and disconnect.
Stopped CLI, restarted, rebooted and I’m at a loss. Originally when I had a issue it was decoding but not processing. Now it’s not decoding at all.
IAX2 show registry is working.:thinking:

Finally figured it out! I had changed power supplies and it was evidently not “clean” and interfered with accepting tones! Put back on my primary power supply and CLI is accepting dtmf commands again! Go figure! Should have used my oscilloscope to look at the audio! :thinking:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.