COS Input Keyed when should be clear

When I bring up View in Asterisk The COS Input shows as keyed when it should be clear and when I key my HT it goes to Clear when it should be Keyed. Another question is my node radio shows an Icon that it is in packet mode. Is this correct? I have a raspberry pi 4 Alinco DR-135 MKIII and RIM-Alinco interface. Having no luck getting this to work.

Is this a ‘NEW’ install ?
did it work correctly at one time ?

ASL or Hamvoip ?

Ham Voip Has never worked.

Well then,
It seems clear to me that your ‘physical COS logic’ needs inverted, electrically.
Should only require a transistor.

So its a problem with the RIm-Alinco then. I will contact them.

That is not what I said.
I am not familure with ‘rim alinco’ so I could not make that statement.

Just that your logic (physical) seems to be inverted.
You should test for that by testing the voltage at the point of COS.
Then perhaps manually injecting the required voltage to see if you get a expected response.

And I am assuming that you have checked the logical ‘invert’ in usbradio/usbraidio.

USB was set to usbinvert when it should be usb. So that is fixed. Still having problems connecting tried echo in asterisk and no response.

First know that echolink will only allow one connect per IP address.
So if you have a PC or a mobile phone with the app, take it off wifi as most phones default and allow the app to run in the background.

Having said that,
you can watch asterisk live verbose from a cmd shell…
asterisk -rvvv
and see what it says when you try to connect. It will tell you a error if there is one.