Connection Failed

I have a node behind my NAT router (50026):
192.168.1.250
port 4569 allstar
port 5198-5200 echolink
port 5201 supermon
The above all works!!! The echolink and allstar can accept connections from outside

I have a second PI running a different node(49267):

192.168.1.249
port 4568 allstar
port 5202 supermon
This node will not connect to the first node…always a “Connection Failed”

I have updated the iax.conf file

[general]
bindport=4568
bindaddr=0.0.0.0

I have updated the the port at the server end to 4568

iax2 show registry
44.98.254.145:4569 Y 49267 68.40.45.218:1025 60 Registered

What have I missed?

···

Darrell Black

(517) 917-2226
GigaHacker@gmail.com
http://www.linkedin.com/in/darrellblack

73 de W8DSB

“In God we trust, all others we monitor”

GMRS WRDE739

https://wiki.allstarlink.org/wiki/Two_Servers_Behind_NAT_Router

You have to configure each node for the other's node number in the [nodes] stanza.

This is due to the IP for your nodes in extnodes being the public IP. This
means node 49267 will try to connect to the public IP for 50026. You need to
set this up so it knows the direct private IP connection.

Technically some routers can be configured to permit this, but most don't.

73's

···

On 7/15/19 10:32 PM, Darrell Black wrote:

I have a node behind my NAT router (50026):
192.168.1.250
port 4569 allstar
port 5198-5200 echolink
port 5201 supermon
The above all works!!! The echolink and allstar can accept connections from
outside

--
Bryan Fields

727-409-1194 - Voice
http://bryanfields.net

Hello Darrell, Did you resolve your issue?

···

Thanks, David

“Laws that forbid the carrying of arms…disarm only those who are neither inclined nor determined to commit crimes. Such laws make things worse for the assaulted and better for the assailants; they serve rather to encourage than prevent homicides, for an unarmed man may be attacked with greater confidence than an armed one.”

Thomas Jefferson

Yes, thank you

Darrell - 73 de W8DSB

“In God we trust, all others we monitor”

···

On Jul 26, 2019, at 10:21, David Shaw shawpbx@gmail.com wrote:

Hello Darrell, Did you resolve your issue?

Thanks, David

“Laws that forbid the carrying of arms…disarm only those who are neither inclined nor determined to commit crimes. Such laws make things worse for the assaulted and better for the assailants; they serve rather to encourage than prevent homicides, for an unarmed man may be attacked with greater confidence than an armed one.”

Thomas Jefferson

On Mon, Jul 15, 2019 at 7:43 PM Bryan Fields Bryan@bryanfields.net wrote:

On 7/15/19 10:32 PM, Darrell Black wrote:

I have a node behind my NAT router (50026):

192.168.1.250

port 4569 allstar

port 5198-5200 echolink

port 5201 supermon

The above all works!!! The echolink and allstar can accept connections from

outside

https://wiki.allstarlink.org/wiki/Two_Servers_Behind_NAT_Router

You have to configure each node for the other’s node number in the [nodes] stanza.

This is due to the IP for your nodes in extnodes being the public IP. This

means node 49267 will try to connect to the public IP for 50026. You need to

set this up so it knows the direct private IP connection.

Technically some routers can be configured to permit this, but most don’t.

73’s

Bryan Fields

727-409-1194 - Voice

http://bryanfields.net


App_rpt-users mailing list

App_rpt-users@lists.allstarlink.org

http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users

To unsubscribe from this list please visit http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users and scroll down to the bottom of the page. Enter your email address and press the “Unsubscribe or edit options button”

You do not need a password to unsubscribe, you can do it via email confirmation. If you have trouble unsubscribing, please send a message to the list detailing the problem.


App_rpt-users mailing list
App_rpt-users@lists.allstarlink.org
http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users

To unsubscribe from this list please visit http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users and scroll down to the bottom of the page. Enter your email address and press the “Unsubscribe or edit options button”
You do not need a password to unsubscribe, you can do it via email confirmation. If you have trouble unsubscribing, please send a message to the list detailing the problem.

This was the missing information that I needed.In the RPT.CONF file you must define the internal address for each node:

50165 = radio@192.168.1.187:4570/50165,NONE
50165 = radio@68.40.x.x:4570/50165,NONE
50165 = radio@127.0.0.1:4570/50165,NONE
49267 = radio@192.168.1.249:4568/49267,NONE ; comment out when on the road
50026 = radio@192.168.1.250:4569/50026,NONE

If you don’t do this they can’t find each other behind the firewall. One warning, my one node is in a ammo box so it goes in the car with me…when I do that I need to comment out that line in the homes nodes or it won;t look for the portable node’s public address.

···

Darrell Black

(517) 917-2226
GigaHacker@gmail.com
http://www.linkedin.com/in/darrellblack

73 de W8DSB

“In God we trust, all others we monitor”

GMRS WRDE739

Well you have a good understanding of whats going on.

···

Thanks, David

“Laws that forbid the carrying of arms…disarm only those who are neither inclined nor determined to commit crimes. Such laws make things worse for the assaulted and better for the assailants; they serve rather to encourage than prevent homicides, for an unarmed man may be attacked with greater confidence than an armed one.”

Thomas Jefferson

I had switched a node from being portable. Put a brand new load on the SD card and configured everything and is Showing Registered from the CLI>
I also set [nodes] in each node server,

Server1
xxx1 = radio@127.0.0.1:4569/xxx1,NONE
xxx2 = radio@192.168.0.56:4568/xxx2,NONE

Server2
xxx2 = radio@127.0.0.1:4568/xxx1,NONE
xxx1 = radio@192.168.0.55:4569/xxx2,NONE

in the rpt.conf and changed the appropriate port for each of the nodes in iax.conf under [general]
As I am trying to setup a two server behind a firewall I had configured both systems one 4569 (28523/28525) the other 4568 (42022) the 42022 in the CLI> iax2 show registry still shows 44.98.xx.xx:4569 state: Registered.
I have both port forwarding the ports to there individual IP’s on the router.
What am I doing wrong?
Thanks,
Marty

you will need to change the port used in the server configuration on the portal.Screenshot%20from%202019-10-13%2015-39-25

Sorry forgot to also say I have different port number Server 1 :4569, Server 2 :4568 that has been done before I sent in my issue. I’ll keep looking. Maybe I fat fingered case or miss a letter or number, something. Thank you.

log into your account on the portal and change the port used for that server.

server 1: 4569 for node 28523,28525

server 2: 4568 for node 42022

your configuration is correct on your raspberry pi’s or whatever computer you are using.

···

Nathan Hardman

nhardman1428@gmail.com

N8THN@ARRL.NET

Nate,
I have checked my account for both servers they reflect the correct port for the node/server used. I did notice my IP is changed from my public IP from the one Echolink reports back. I am logged into the system, I see my eEcholink node listed but when anyone tries to connect it times out. Now I am using a AT&T Hotspot Allstar is working great! I even used Qtel for Echolink and it is working. So at this point I’ll get hold of the Echolink floks and see what they say.
TNX, 73,
Marty