Compiling from source failure

i’m trying to build allstar from source and a nonestandard platform
i downloaded to source from github, ran the ./config files which succeded but when i tried to compile, i got this

…/astver.h:55:10: fatal error: zaptel/tonezone.h: No such file or directory
#include <zaptel/tonezone.h>

according to the documentation, zaptel is no longer used and dahdi has take it’s place so zaptel isn’t needed. so how do i get past this error?

thank you

It might be helpful to know what source you are working with and the directions you are following.

But you have this in the wiki…

this one

You need to install DAHDI first. I think it provides tonezone.h.

i did , including the source and it didn’t.provide tonezone
i even did a search for tonezone. there was no sign of it.

$ apt-file search tonezone.h
libtonezone-dev: /usr/include/dahdi/tonezone.h

well it’s there at /usr/include/dahdi/tonezone.h
butg when i do a make i still get

“In file included from chan_voter.c:209:
…/astver.h:53:10: fatal error: dahdi/tonezone.h: No such file or directory
#include <dahdi/tonezone.h>”

is it looking in the wrong place?

it appears that apt-file was not truthful
it reported the file /usr/include/dahdi/tonezone.h
but when i looked there, it did not exist and sourcing eslewhere caused compile errors. very strange. perhaps the answer is to build from source rather than using apt