Command to disable node Tx?

Via a bash shell script, I would like to interrupt the node radio Tx when a certain condition is met.

“lsusb” returns:
Bus 001 Device 004: ID 0d8c:0013 C-Media Electronics, Inc.

which is what is interfacing the node radio.

Is there a command which can immediately interrupt the node radio Tx, please?

I suggest doing that with controlstates. In rpt.conf uncomment and change statenum 1 to rptdis. Then you can activate the state from a script with asterisk -rx "rpt cmd yyyyy cop 14 z" where yyyyy is your node number and z is the state (0 or 1).

;statenum = copcmd,[copcmd]...
0 = rptena,lnkena,apena,totena,ufena,noicd  ; Normal operation
1 = rptdis,lnkdis,apdis,totdis,ufdis,noicd  ; Example repeater disabled 
;2 = rptena,lnkdis,apdis,totena,ufdis,noice  ; Repeater only operation

Hope this helps. Let me know if you have questions.

The accompanying announcements “FF1” and “FF0” are not silenced with the -m option to asterisk. How to silence them, please?

Sorry, I don’t know what FF0 and FF1 are. Have any more details?

Rereading this thread, I’m lost. How can lsusb cause app_rpt to speak?

That said, if you want to turn off command speech response and not allow users to turn it back on, make these two edits to rpt.conf.

telemdefault = 0     ; 0 = telemetry output off
                     ; 1 = telemetry output on (default = 1)
                     ; 2 = timed telemetry output on command execution and for a short time thereafter.


telemdynamic = 0    ; 0 = disallow users to change the local telemetry setting with a COP command
                    ; 1 = Allow users to change the setting with a COP command. (default = 1)

However, you’ll still get a function complete beep, I believe.

You have these…
Check your rpt.conf if using DTMF for your assigned command.

=cop,3 ; System disable
=cop,2 ; System enable

rptena,rptdis - Repeater Enable/Disable