Can't flash Allstar to work on Pi 3A+ any more!

I have a working version of Allstar Arch Linux ARM Raspberry Pi 3A+ from a couple of months ago. I recently bought a new Raspberry Pi 3A+ and can not get any of dozens of different Flashed micro SD chips to boot on it. I sent back the Pi and bought another from a different supplier (Both were authorized distributers - CANAKIT and PiShop) and nothing will boot. Both of those Pis worked fine and booted OK with the ‘official’ Raspberry Pi OS. My old working system flashed chip will not boot on the new Pis, but still works fine with that micro SD and the new ones I flashed.
I was advised that these Pis can have changes in them and if they boot the ‘official’ OS then they are acceptable.
Is there some way to get this system working? Can I build from a working OS for example? Any help would be appreciated!
73 - Mike VE3EQP 59106 …>

You might try this

Tried the Allan-N install, but failed twice in step 3 “ASL-DAHDI/tools autoreconf failed”, then locked me out with no Usename and Password for Github.
I’ll keep trying with other valid Username and Password for Github.
But, any other ways? I think I’ll keep geting this fail!
Mike VE3EQP 59106 …>

Perhaps a dumb question by me. Have you verified that a working ASL version exists for the PI3 A+.
Apparently Hamvoip has a version that works but does ASL??

Larry - N7FM

Looks like the image you have does not come with the right driver for the device you have. Or something like that. If the image works on an old RPI that you have you could maybe run an auto-update and try it again on the “new” to you PI?

Larry et al;
I do have a good working system with an RPi3A+, whose box and stampings are the EXACT same as both of my ‘NEW’ ones. They all ran the standard Debian Bookworm OS but neither NEW ones will boot the existing working AllStar micro SD that runs fine on the OLD system. My main idea was to have a fully working SPARE system, cross compatible.
I’m now burning the ‘latest 2024-03-15 Bookworm OS’ and will try to work Allan’s Github AllStar Install after getting updates when I get it back on Internet.
I am learning more about Github and the commands so I should get through it again. After the Failed status, it told me to check “/vsr/tmp/build-dahdi.txt” for details, but that was, and still is, Greek to me, as I don’t know how to do that (YET!).
Struggling on! Thanks for input. Mike VE3EQP 59106 …>

you need to copy over onto the SD card root directory two files copied from the latest OS version
fixup.dat and start.elf and all should then be well.