Cannot start dialtone error * FIX *

Ya know my memory is short for things that I do not run into all the time.
And as always this error would come up on the lists all the time. But I had been away for a couple of years.
So, I finally ran into it myself on one of my virtual systems that I was adding sip and a did to.

So, after looking in /var/log/asterisk/messages and cleaning up errors that were clearly there after a reload, which I would suggest everyone do from time to time and especially when having any error.

Well, I still had the issue and was thinking of recompiling asterisk and dahdi.
But I decided to compare this install which was on a 512mb vps with a working vps @1gb.

So here is what worked for me as I use this in other twisted options in app_rpt for other functions.

rpt.conf
60=autopatchup,context=radio,noct=1,farenddisconnect=1,dialtime=90000,quiet=1

Now your context should already be set for ‘radio’ and you can check your node setup for that declaration to be sure. But putting it in the AP setting makes sure it is there for it anyway, or you may choose a new one.

Be aware that whatever context you choose, you will need dialplan extensions under that context in extensions.conf or use a goto to jump somewhere else from there if needed.

In any case this worked for me. quite=1 and works as intended.

I am guessing that when it is not stated in the command string, then the default is quite=0

A look in the source revealed this…

/* start dialtone if patchquiet is 0. Special patch modes don’t send dial tone */
if ((!myrpt->patchquiet) && (tone_zone_play_tone(genchannel->fds[0],DAHDI_TONE_DIALTONE) < 0))
{
ast_log(LOG_WARNING, “Cannot start dialtone\n”);
ast_hangup(mychannel);
ast_hangup(genchannel);
myrpt->callmode = 0;
pthread_exit(NULL);

Obviously patchquite (var) is referring to internal status’s and I’m not going to search it out past this, for now anyway. It appears there may be other issues effecting this internal var.

If I understand everything correctly, then with the above configuration, dialtone, patchup and patchdown announcements will not be available.

What are _

Announcements ?

When an autopatch is activated and when the connection is terminated, app_rpt provides the ability to play the corresponding voice notifications.

You would need to put those playback options in your dialplan.
It’s not a default function of app_rpt (built in)

These are default options.

https://wiki.allstarlink.org/wiki/Rpt.conf

[telemetry]
patchup=rpt/callproceeding
patchdown=rpt/callterminated

I stand corrected.

You should put in for a refund !

Well, I should not have labeled the post as a fix, but a work-around.
Something I have been doing for asterisk/app_rpt to get what I want/need for a long time.

To be honest, I don’t know where things went wrong with that.
I have suppressed messages since the days of acid.
I guess that depends on if your system is used by people and they get tired of needless system talking, or you run a personal station and want to impress your friends.

But I suspect the whole issue of dialtone has something to do with settings when you add a trunk.
Being nat, nat settings, canreinvite etc / some combination ?
Something flags the software wrong/unexpected for the sequence.

But one would think for all those that complain about it, someone would investigate further.
I am happy with a work-around. I likely never noticed because I have been using that patch string for 10+ years for special work-around functions unrelated.
For it is the only way you can enter dtmf in a way to have a true var to evaluate/execute inside of the asterisk/app_rpt/radio channel.

I may experiment with it later to find out what the exact issue is, but I have I have bigger steer to barn for the moment. Some have been waiting many years.

You might ask the devs working on beta2 to investigate/fix for upcoming release ?

This is community sourced software and nobody pays a dime for it. Few work for it. Everyone enjoys it.
I guess it comes down to how important to you it is.
A complaint is not a fix. You didn’t just buy a new car or even a dollar store trinket.

Thanks for this, it fixed my autopatch. Autopatch worked for years and then I noticed the dreaded “cannot start dialtone” issue. Not sure what changed but glad to have the feature back.

73

Kyle
K0KN