Autopatch VOX settings, can't find them

Howdy All,

We live in a rural area where we not long ago lost all phone, internet and 911 due to a fiberoptic cable being cut. So we are adding an autopatch to our local repeater. We have it working, a Pi3 to a Master Communications RA-40 and a CDM1250.

I can’t find the VOX settings in rpt.config as outlined here:

Where might I find it? Currently it is too long and a person that does not know how a radio autopatch works can answer the phone and keep saying “hello…hello…” too quickly and never let the VOX drop until they figure no one is there and hang up.

Another question, is it possible to make the party on the phone hear a tone when the VOX drops?

The answer is in the link you posted to the wiki.
I assume this is a simplex phone patch. Settings example at the end.Those are the only known settings.

You could try enabling the CT in the phonepatch command string in rpt.cof and should make it on the radio side.

We have always had to explain repeater phone patch to potential call’es even in full duplex.
Most ecom dispatch/911 are trained to know when you say ‘THIS A RADIO PHONE PATCH’ not to talk when you are as it is one sided.

But it is just a tough thing to do in a simplex mode. If it really is needed/required, I would suggest a full duplex radio system. VOX makes it possible on simplex, but that is not saying much for quality.

Simplex Autopatch[edit]

For nodes with duplex set to 0 or 1, Simplex Autopatch operation is supported.

This is accomplished by using a VOX on the audio coming from the telephone call,

because of the half-duplex nature of the node. To avoid having audio from the

telephone call keep the transmitter engaged for extended periods of time (if there

is some source of continuous audio), there are two time-out values. One is the

Vox timeout, which is the maximum amount of time that the VOX can hold the transmitter

engaged, which by default is 10 seconds. The other one is the Vox recovery time, which

is the amount of time that the Vox is disabled during times of continuous audio, after

the Vox timeout, which is 2 seconds. So, during continuous audio, it transmits for

10 seconds, then stops for 2 seconds (so that you can transmit to it and perhaps

disconnect the call), then transmits for another 10 seconds, then stops for 2 seconds,

and so on.

Additionally, to prevent ‘chop-off’ of the first syllable or two of the audio from the

telephone call, we delay the audio to allow for the transmitter to start transmitting

and any CTCSS tones to be decoded. This delay is typically 500ms, but can be adjusted

via the ‘simplexpatchdelay’ parameter. It is specified in units of 20 milliseconds.

These time-out values may be overridden by using the following configuration parameters

located in the [] section of rpt.conf:


voxtimeout = 10000 ; vox timeout time in ms

voxrecover = 2000 ; vox recover time in ms

simplexpatchdelay = 25 ; Delay for transmit while in patch in 20ms increments

Hi Mike ad thanks for the reply.

The problem is that the voxtimeout, voxrecover and simplexpatchdelay settings aren’t in the rpt.conf file. Can they simply be added?

However, reading through it again, I don’t think any of those setting do what I want anyway. Our problem is how long the VOX holds the radio in TX after the phone side stops speaking. It feels like about 1500ms. With a person not accustomed to radio, this seems like a long time. So they say hello or speak again and keep the VOX engaged, not allowing the radio user to speak.

I suppose we could lower the voxtimeout (if I can find it) but that seems less than ideal as it limits how long the phone person can speak. As the patch is for radio users that can hit our local repeater it will have to be a simplex patch.

And another issue, when we set quiet to 0, the patch does not work at all. Just dead, nada. Any idea why that might be? It would be nice to have some user feedback.

Thanks again!

Yes you can add the lines to the rpt.conf file

These time-out values may be overridden by using the following configuration parameters

located in the [] section of rpt.conf:

voxtimeout = 10000 ; vox timeout time in ms

voxrecover = 2000 ; vox recover time in ms

simplexpatchdelay = 25 ; Delay for transmit while in patch in 20ms increments

Thanks for the reply! Good to know that I can add them. My next question is:

From reading the wiki it appears that none of those do what I need. What I am looking for is the delay after someone on the phone stops speaking and the VOX dropping. If I read the wiki correctly, none of these do that.

voxtimeout = maximum time that the vox can hold the ptt down. If they are still speaking it will drop after this time.

voxrecover = how quickly the vox cabn re-engage after timing out.

simplexpatchdelay = prevents losing the first syllable from the phone side.

If I am correct, none of these address the problem we are having. Someone answers the phone and says hello. Before the VOX drops and gives the radio user a chance to answer, they say hello again. This continues until they conclude that nobody is there and hang up. The VOX hangtime seems to be about 1500ms. 500 ms might work out better. Is there a setting somewhere for that? Something must control the hang time.

Many thanks for the help!

Well, yes there is a issue with quite=0, so you need to set that to one.
But noct=0 as well if you want the ct to be heard on phone and radio, but only activates (as far as I know) from radio action cor drop.
as @N8PC said, you can add those to your rpt.conf file in the stanza of that node, or any node intending tou use the PP-vox.

You have control of the radio side with your tx, but only when the PP-vox times allow.
I think perhaps you are thinking of it a bit in reverse, but perhaps I am wrong about that.

Hate to repeat myself, but you will find this a whole bunch better under a full duplex radio system.
You have only a basic set of making it function under simplex. It’s not ideal by any means. It does work with lots of limitation.

You are going to have to fiddle with the timers till you get something that kinda agrees with you.

Me? Look at things backwards? Inconceivable!

More than likely I am and I appreciate your patience. Where do you think I am looking at it backwards? Is there a setting that dictates how long the VOX holds after silence is detected? Obviously there has to be some, otherwise the VOX would drop at the slightest pause in speech in the phone side. But as I said it seems to be around 1500ms, maybe 1000. That really is the only issue that is problematic at this point.

Forgive me if I have this wrong, but a user with a radio in their car or handheld can’t operate full duplex. That would take a repeater to repeater connection, no? Or I am I misunderstanding?

Again, thanks for the help, it is much appreciated.

Folks’ terminology differs, but here it goes…

Think Full (half-duplex) - one method of that is aka cross band repeat.
Gives you all the benefits without duplexer. But second radio/node required.
It is the best that can be achieved without a full duplex repeat.
You simply do not have any signaling methods with simplex.

Yeah, not possible to do a full duplex patch.

So, is there a definitive answer about is there a setting for the VOX drop? Do I understand the available settings as posted above?

As the text states, you have a 500ms audio delay so that if ctcss was used, it has time to activate it before the audio begins. It may be slightly higher. Add that to any other delays…

When they stop speaking, it is to drop as I read it. (but not if it is a noisy connection of background)
But if they continue to speak/noise, it will run till timeout (voxtimeout = 10000), giving you 2 seconds (default voxrecover) to recover conversation or command (window).

These timers should not apply to the radio side if you are using a cos trigger.

Perhaps your issue is the background noise on the phone side (vox threshold does not appear settable for this ?)
voxrecover is your window to take control of the conversation, or command it.

Perhaps try some testing with a clean background line just to be sure it is not an issue.

But no setting of delay after voice stop to tx drop.

Are you using simpleusb or usbradio ?

We are using simpleusb.

Good suggestion to see if it is background noise. I am at work in the middle of a 48 hour shift but will test when I get home.

Many thanks for all of the help, I do indeed appreciate it.

Well, you are in unknown territory to me, and I am curious.
There are some minor bugs here and there in the software.
So, if all else checks out, perhaps try switching over to USBRadio for different results and let us know so it may help others.