Audio dropout but not due to packet loss

Using a Repeater Builder RIM-Lite with an SBC (86x_64) running ASL under a Proxmox VM and I am doing so on several different computers. One thing I do with such a setup is play a .ul audio file (NewsLine, using the localplay command) and it works great. HOWEVER, I’ve been experimenting with some newer, lower power SBC (that run directly on 12v @ around 15-20 watts) and have experienced random audio dropouts of the played back .ul file. I’ve tried both the simpleusb and usbradio drivers with no change, as well as USB 2.0 and 3.0 Ports.

Has anyone else experienced such an issue?

What happens when you run “sudo dahdi_test -c 100”? (If I run that on a Dell Wyse 3040 I get all 99.9+%.)

root@testASL:~# dahdi_test -c 100
Opened pseudo dahdi interface, measuring accuracy…
99.994% 99.997% 99.990% 100.000% 99.994% 99.993% 99.986% 99.997%
99.993% ^Z
[1]+ Stopped dahdi_test -c 100

I would think that the problem is in the RIM.
I have seen it before, or at least the complains, and you might find something if you search the forum.
But as I remember it, a call to RIM manufacturer was needed. Something to do with a bad batch of chips in one instance.

Hope that is not your issue, but it does explain why you can do a playback from file without issue but not from input from the rim.

Mike, perhaps I wasn’t clear. The audio file playback is what has intermittent drops of audio on certain hardware (computers).

But I will contact Scott in any case, thanks

Sorry if I misunderstood.
Well then, Sounds more like a bitrate/codec issue in memory.
Generically, drop-outs are a result of inability to refresh fast enough for memory/cpu etc.
But the question becomes if all seems good, what may be causing excessive use in the system.

Have you tried some other lower bitrate codec ? or even a higher one

OH… I might ask how many outbound streams (connected nodes) ?

I’ll try some different bitrates and report back. As for connected nodes, none. And processor load is negligible

To clarify, the codec selected in iax.conf is used for sound file playback as well as the VoIP aspect or do the sound files ALWAYS use the alaw codec?

As far as I know, you would be using the codec native to the sound file format.
If that were different from the ‘allowed’ codec, I’m sure it is trans-coded to that format. But I guess that is double the work. I do not know how asterisk preforms this feat.

But some experimenting is in order to narrow it down a bit.

I might suggest using files saved in ‘format’ module and not codec.
ie wav, WAV, MP3 etc.
Just make sure the format module is enabled.

Just one more curious question…
Are you using monitor ‘ducking’ on those affected ?

Sorry, you lost me.

Format module?
Monitor ducking?

If you mean modules.conf loads the .wav drivers, mine is set up to do so however I can’t seem to get my audio files to play the .wav format. What am I missing?

For example:

root@testASL:~# /usr/sbin/asterisk -rx “rpt playback 1103 /etc/asterisk/audio/newsfiles/news.wav”

Perhaps what you are missing is…
There are 2 different WAV formats.
.WAV and .wav. The asterisk format module supports .WAV (caps)

Audio PCM uncompressed 16bit 8khz mono(1 channel)

I believe I used ‘sox’ for conversions unless I recorded it with asterisk in the fist place (best when possible).

Monitor ducking is a setting to lower the output on the local node of ‘monitored’ nodes when local traffic is present.
If you do not know about it it is doubtful you are using it.

Well, converted to WAV:

/usr/bin/sox /etc/asterisk/audio/newsfiles/news.wav -r 8000 -c 1 -b 16 /etc/asterisk/audio/newsfiles/news2.WAV

When I issue command to play, TX keys for a few seconds then drops (with no audio).

Well, I have no time to check your syntax. Don’t use this much anymore and don’t remember.

But be sure this module is loaded
load => ; Microsoft WAV format (Proprietary GSM)

I may have mislead you a bit. It would be compressed…
compressed with GSM codec(would be the capital extension .WAV)

Would you like a method to play AR Newsline back directly from MP3 no conversions ?

I am assuming you are not breaking it apart in segments to allow a break and not worried about timeout.
Although I was working on a good method to do this and auto break apart to avoid timeout, but stopped working on it many years ago. It was just getting to complex for the average user to implement. And I hate writing long howto’s. But the simple and straight forward method is easy to implement.
I don’t play arnews on my nodes, but I use the mp3 player for other stuff. and I just tried it with the ARN service and worked fine for me on a 4 radio-node PC server (2ghz 4GB).

The following explains what I’m doing:

It works great but I’ve been changing out the computers at the various sites to ones that run directly on 12V and use less power. I had no problems with playing Newsline until I started changing computers, hence my starting this thread.

The 12v has nothing to do with it unless the power supply is wimping out or getting noisy from a near limit load…

Curious what the old cpu and new cpu are ?
A difference in cpu cacheing ?

I agree, the fact the new SBCs run off 12 volts means nothing as long as their power source is stiff enough (which it is)

“OLD” CPU is Intel I5-4750. New computer(s) use Intel N5105

Both are 4 core, 4 thread processors with comparable speed ( > 2.5 ghz) and amount of RAM (8 gigs)

Only one off the path suggestion…
Update the bios/firmware
When I have seen these mini pcs have strange bottlenecks, often it is in usb/interupt handling.
It simply takes them to long to figure out which port needs attention on a interrupt request.

Also, for a test, it might be worthwhile to turn off usb headers not used as they share interrupts often.
So that could cut some delay if that is the issue.

But I would check/update bios/firmware in any case