ASL trouble running a disconnect from command line

I’m not sure I’ve ever don this on this node before.
I was trying to setup a crontab but i can’t even get the commands to via ssh command line.

/usr/sbin/asterisk -rx “rpt fun 523800 *11997”

should’t this disconnect private node 1997 from main node 523800?

Looks right. Do you get any response from that when you run it on the CLI? Also open another ssh session and watch the asterisk CLI when running the command from the first session.

yeah this is really weird I think the syntax is right something else must be going on:

root@ip-172-31-27-215:~# /usr/sbin/asterisk -rvvvvvvvvvvv

AllStarLink Asterisk Version 1.01 2/13/2018 GIT Version 004b9dd
Copyright © 1999 - 2018 Digium, Inc. Jim Dixon, AllStarLink Inc. and others.
Created by Mark Spencer markster@digium.com
Asterisk comes with ABSOLUTELY NO WARRANTY; type ‘core show warranty’ for details.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type ‘core show license’ for details.

== Parsing ‘/etc/asterisk/asterisk.conf’: Found
Connected to Asterisk GIT Version 004b9dd currently running on ip-172-31-27-215 (pid = 2828)
Verbosity is at least 11
ip-172-31-27-215*CLI> rpt fun 523800 11997
ip-172-31-27-215
CLI>

I notice after i run a command it’s makes allmon quit controlling the node until i restart asterisk.

Alternatively, I tried rpt cmd with the same results. Neither seems to work. :frowning:

where is the *before 11997 ???

···

| Garanti sans virus. www.avast.com |

  • | - |

Le ven. 21 août 2020 à 17:46, Russell Thomas via AllStarLink Discussion Groups <noreply@community.allstarlink.org> a écrit :

KV4S
August 21

yeah this is really weird I think the syntax is right something else must be going on:

root@ip-172-31-27-215:~# /usr/sbin/asterisk -rvvvvvvvvvvv

AllStarLink Asterisk Version 1.01 2/13/2018 GIT Version 004b9dd

Copyright © 1999 - 2018 Digium, Inc. Jim Dixon, AllStarLink Inc. and others.
Created by Mark Spencer markster@digium.com
Asterisk comes with ABSOLUTELY NO WARRANTY; type ‘core show warranty’ for details.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type ‘core show license’ for details.

== Parsing ‘/etc/asterisk/asterisk.conf’: Found
Connected to Asterisk GIT Version 004b9dd currently running on ip-172-31-27-215 (pid = 2828)
Verbosity is at least 11
ip-172-31-27-215*CLI> rpt fun 523800 11997
ip-172-31-27-215CLI>


Visit Topic or reply to this email to respond.


In Reply To

wd6awp ASL Admin
August 21

Looks right. Do you get any response from that when you run it on the CLI? Also open another ssh session and watch the asterisk CLI when running the command from the first session.


Visit Topic or reply to this email to respond.

You are receiving this because you enabled mailing list mode.

To unsubscribe from these emails, click here.

| Garanti sans virus. www.avast.com |

  • | - |

The site must have dropped it formatting what I pasted. It is there.

Looks like it italicized it.

1 Like

When posting on Community put commands in single back ticks to prevent unexpected formatting: *11999

1 Like

Verbose 11… really?

2 Likes

You can do a tail -f /var/log/asterisk/messages to see what asterisk is doing.

You stated “AllStarLink Asterisk Version 1.01 2/13/2018 GIT Version 004b9dd”

I would suggest an upgrade to the current version.

nothing shows up:

How would I go about that? This server is Ubuntu 16.0.4 and I manually installed with these commands from the wiki:
cd /tmp
wget http://dvswitch.org/install-allstarlink-repository
chmod +x install-allstarlink-repository
./install-allstarlink-repository

If Raspbian: apt-get install raspberrypi-kernel-headers -y
Otherwise: apt-get install linux-headers-`uname -r` -y apt-get update

apt-get install allstarlink -y

I held the kernel headers.
i ran apt-update and apt-upgrade but the version stays 1.01.

shouldn’t rpt fun and rpt cmd work on this version?

I run ASL 1.01 on a VSP installed per the WiKi docs. And yes, fun and cmd work.

1 Like

That’s what I thought.
Can you think of anything else I can check? Could something be wrong in the rpt.conf in relation to commands?

First thing: *cli> core set verbose 3 so you can see what the heck is going on when you test your commands.

Are you saying that *cli> rpt fun 523800 *11997 doesn’t work… no response… no nothing? If so you have a very basic problem. Are you connected in the first place (that’s a disconnect command, you know)? Do nodes 523800 and 1997 actually exist on your server? Because if they don’t exist or your not connected (and using a disconnect command) a nothing response is normal.

Here is what I did:

  1. I logged onto Allmon and verified i can disconnect 1997 from 523800 from there and it worked.
  2. I logged onto ssh and tried it and nothing happens. it just returns to a blank cli line.
  3. Afterward I can no longer disconnect from Allmon until i restart asterisk.
    Here is a screenshot:

Ah ha! That’s the problem. You have to do a permanent disconnect for permeant connections. *1 won’t work.

Set up commands for permeant connects or use cmd with ilink 11.

; End Mandatory Command Codes

; WD6AWP added
xxx = ilink,11                  ; Disconnect a previously permanently connected link
xxx = ilink,12                  ; Permanently connect specified link -- monitor only
xxx = ilink,13                  ; Permanently connect specified link -- tranceive
xxx = ilink,6

Lord, I feel like a dummy now.
I haven’t done this often with ASL so I knew it had to be something I was doing wrong, LOL.

Anyway, that was it.
I used rpt cmd 523800 ilink 11 1997 and it appears to work.
I’ll see if i have any luck with CRON now.

Thanks Tim, and everyone that commented.

73,
Russell, KV4S

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.