ASL run simpleusb-tune-menu

I have several issues I’m working on. It’s a PC Dell laptop that I loaded ASL on. It show active on ASL and I can connect EchoLink.
When I select menu simpleusb tune menu,
Selected item #4 ===> Run simpleusb-tune-menu for SimpleUSB configuration.

Does nothing other than to keep telling me…
“SimpleUSB must be enabled in modules.conf and selected in rpt.conf”
I checked those files and they look good. So I run from the command line and it runs.
I’m unsure why it won’t run from the menu?
Also my usb_29978

when I try to test from the command line I get, usb is not active.
What am I missing here?

for the node in question…
lets see your line in rpt.conf of the channel driver load

and your simpleusb.conf

Do you have the device id’d corretly from ‘lsusb’ to your simpleusb_radiotune file ?

No, I’m trying to test the interface I built and needed to solve the two problems first.

No correct id… no see

How else would it know how to find it ?

Bus 003 Device 002: ID 0d8c:000c C-Media Electronics, Inc. Audio Adapter


Where do I set that up? I’m new at this.
As far as I got. Thanks

you need to type lsusb to get a list of the usb devices and locate the c media sound dongle
use example above to put that data in file


it should look like this inside (my node num)


you can run the tune menu again to set levels, see if it can find it now.

I don’t know if there are any issues with the beta on this, as I have only hubs using beta6
and have always set mine manually anyway, so I’m not a good guide past this point.

Tell us how it turns out.

Found media
But if I type in root
/etc/asterisk/simpleusb_tune_usb_29978.conf Permission denied

su /etc/asterisk/simpleusb_tune_usb_29978.conf no password entry

Sudo /etc/asterisk/simpleusb_tune_usb_29978.conf command not found

sudo nano /etc/asterisk/simpleusb_tune_usb_29978.conf

if you are root, you can drop the sudo

nano is a file editor, the file is not a executable, but a text file containing configuration settings

By your first picture you don’t have it active. Put a ; in front of DADHI and take the ; out in front of the SIMPLEUSB/USB_29978 then restart Asterisk.

Good catch @Tony , I was looking for typos that are common in the naming of the usb port. LOL

Thanks, now I can see my keying circuit working when I talk on EchoLink connected to my ASL node but no audio. When I try to tune I’m getting I have to setup in .rpt and .modules
More investigation to do.

While the first rule of thumb would be to verify your audio at the radio source, then at your sound dongle, and if that appears to be good, you may have your logic inverted a bit for the audio gate switching is not necessarily in sync with the ptt/cor switching.
You may have to change the logic of your cor and or ptt to match.
Will get more confusing depending on your duplex modes.

You may want to set everything to full duplex for testing, till you get the logic right.

This one will keep you thinking for a bit. Take your time, you will get it.

Got my ptt keying device to work, kinda. Have several issues.

  1. Keeps resetting USB and when it does it changes the RX and TX levels. If I lower them by manually simple usb-tune-menu I can’t save them. Tune menu doesn’t work from ASL-menu because it says it needs to be enabled in .rpr and modules.
  2. USB keeps resetting and has something to do with rx and tx levels and link radio. Tried diode on 2n2222 to bleed any residual on ptt to ground.
  3. Can’t edit file above with devstr=7-2:1.0 I was in it before but says it doesn’t exist and want to look at it because of usb resets.

A couple of notes…

If you unplug the usb device and plug it back in, you will need to verify the device string/id is the same.
They don’t call it plug and play for nothin…LOL

You will want to be sure the channel driver is set to load in modules.conf
(don’t think you have a issue here but check it)
If not using radiousb, you can set it to ‘noload’ while you are there.

What is the model of sound dongle you are using
The chip id… cmedia cm108 ?
It will show on lsusb

Hopefully, you are using a buffer transistor on the ptt line as there is likely not enough current sinking ability for many ptt’s. And that will definitely throw things off in strange and unpredictable ways.

Something else to at least look at is rf on any lines.

We shall see how far that gets you…

Success! Used a 560 resistor with the 2n2222 for PTT AND RF was getting into FOB with HT antenna so I installed a mobile antenna and moved it to the shack door. Also the 2n2222 spec sheet had improper indexing but Wixipeda had a homemade drawing that was correct. Hung one in the air to test, go figure!

Also when the FOB was resetting it was assigning a new device address, bus and the operating system was automatically finding it, a good thing!

All is well, thanks for all your advice!

Now I just have to find a COR/Busy on the HTX-202.

Not directly familure with your radio… (could be but don’t remember LOL)

The quick and easy if the radio has a ‘busy light’ is to use that and I always suggest using a buffer transistor to be sure you have enough current for the task and not affect the radio.

If you look at the diagram on page 39 here

you will see a busy indicator on the left of what looks like a header strip.
Check the voltage to see if it is active high or active low and that the voltage is going high or low enough for a transistion for your fob
But I still contend to use a 2n2222 or 3904 3906

Thanks, I saw that before but was deterred when I cracked open the radio when I saw the flexible header strip. I said, what do I have to loose! Opened it again, determined which was pin 10, towards top of radio, 26 at bottom and soldered a green wire and ran it through bottom screw hole that secures battery plate.
Turned on radio and got Err1 on display. Evidently soldering iron caused a discharge, should have dug out my soldering static mat. Lesson learned! Checked manual and it showed how to clear. All it well.
COR/Busy pulls up. No Busy (4.9mV) Busy (4.893V)
Now I have to figure out a circuit for COR that pulls up voltage.
My elmer became a SK in December, sure do miss him.

Got carrier now, set to active low with 2n2222 acting as buffer. See picture.

EchoLink connects to Allstar node and receive RX audio through it but if I TX on portable radio on node simplex frequency just scratchy white noise :thinking:

From searching Allstar forum for RX audio it may have something to do with my buffer 2n2222 circuit design as FOB Carrier detect going to ground and not 0V ?
Looks like I need to add a pull down resistor. Probably should measure voltage on fob cos detect to determine size of resistor.

FOB COS is 3.3V
When RX is received drops to 135-150 mV.