ASL 1 image file problem

Hi all. Trying to build up a Pi controller for a blind friend. So I got the image zip file ASL_1.01-20180228-armhf-raspbian-stretch-image.zip and unzipped it. Burned the image to a microSD, boots the pi just fine but I needed to get his old configs. I moved them to a virtual server I have in dallas and to get them I need to ftp into the new pi. Brick wall time. The repositories the asl image will go to have all newer versions of stuff. I tried to get ftp first, response basically says cen’t get it so pointed my web browser at the site (mirrordirector.raspbian.org) and dug my way down to the ftp files. The one the pi wants is /raspbian/pool/main/n/netkit-ftp/ftp_0.17-34_armhf.deb and the one in the repository is mirrordirector.raspbian.org/raspbian/pool/main/n/netkit-ftp/ftp_0.17-34.1_armhf.deb

So won’t download. Ok, I downloaded it and tried to install with apt install ftp_0.17-34.1_armhf.deb and THAT blows up because the version of libc6 isn’t correct for that newer deb file.

Is there a trick to getting stuff from repository? My brain still hooked on slackware which is entirely different.

Also the image comes up looking for GB keyboard (???)

And dahdi seems missing and when go to compile get a bunch of errors:

scripts/Makefile.build:303: recipe for target ‘/usr/src/asl-dahdi-linux-2.11.1/linux/drivers/dahdi/xpp/xbus-core.o’ failed
CPU Architecture ‘arm’ does not support VPMADT032 or HPEC.
/usr/src/asl-dahdi-linux-2.11.1/linux/drivers/dahdi/xpp/xbus-core.c:1615:2: error: implicit declaration of function ‘init_timer’ [-Werror=implicit-function-declaration]

  • init_timer(&xbus->command_timer);*

What am I missing here?
GeorgeC W2DB

ASL 1.01 uses deb9 …not supported for many things and growing.
You might point the repos to deb10 and find success.

I just gave up and re-installed the image and didn’t update it. Managed to get what I needed by using wget would have preferred ftp. Next issue is how to create the call letter node number files. What I have found by google search is incomplete, nla, etc
GeorgeC

I am guessing that you are refering to node number ID sounds files.
They would be located in
/var/lib/asterisk/sounds/rpt/nodenames

The system looks there first for the node number and plays the matching nodename by number.
If it does not exist, it then plays the saydigit value.

Well yeah, that I know but I needed something to generate the files. The image file only had about ten nodes in that directory. Last time I did this I had to run a script file to go generate the .ulaw files. I assumed they would be in the distro. I zipped all I had in another node and placed them in this rig I’m working on

GeorgeC

George, I don’t remember that ever being part of the package but could be.

A private individual manages a DB of nodenames.
As I have it written, I placed a rsync command in my crontab that looks like this…

00 00,12 * * * /usr/bin/rsync -av rsync://reflector.kb2ear.net/nodenames/ /var/lib/asterisk/sounds/rpt/nodenames/

So it updates on an interval. I’m sure there is a post about it somewhere here if you look.