AllstartLink Debian 11

Greetings allstarlink developers team, I would like to know if there is an updated repository for debian 11, or an official step-by-step procedure that works to start an allstarlink node with debian 11, it is incredible that an application as successful as allstarlink has been frozen over time, and it does not work with current operating systems, apparently the only way to get allstarlink up and running at present is by downloading the raspberry image, which happens with users who use vps or servers, there are 3 repositories but none of the installation procedures work, or libraries are missing or there are broken links, but it always gives an error, please if you have any step by step to install in vps with debian 11 I appreciate your collaboration. regards

Off the cuff, I would say relax a little. The OS just came out, and it looks like it’s not going to work ‘out of the box’.

I do know the dev team is currently still working to make the beta 2 of asl work on deb 10.

Perhaps that puts things in perspective,
But I would be interested
in what you would expect to gain under debian 11 that is not under debian 9 or 10?

Asterisk stopped supporting app_rpt some time ago, so we are kinda on our own to keep the software running under later software versions that support our needs in audio/dsp handling etc.
Each OS version breaks the supporting files.
We need new interfaces to make the magic work over time. But the goal line keeps changing.
The supporting library’s change making our stuff incompatible in subsequent versions.
That is what the dev team is facing. Hope you can understand and sympathize a bit.

But, Now is your chance to tell the dev’s what you are expecting. Perhaps they are listening.
But I’m guessing they are well aware of the challenges ahead.

1 Like

I am not upset , maybe a little frustrated that no tutorials or guides that will work at some time , today it does not work , making it difficult to use the application , it would be good to add the nonexistent libraries to the github repositories , to guarantee that the installation steps yes they work, and the installations are not interrupted due to lack of libraries, and tried to install by command line in must 10 and 11 on raspberry, also try in must 9, 10, 11 with official repositories with beta and even build, all attempts they were negative for different reasons, dah errors, lack of libraries or non-existent links, the only way to start the application was downloading the pre-installed image for raspberry, and it works perfectly. I do not expect anything from Debian 11 , but it would be of great help to the government of amateur radio if the installation lines worked in the version that the developers indicate , because at the moment it does not work , I currently have the raspberry image operating with usrp a dvswitch perfectly , I would like to achieve the same thing on a vps of version x , indicated by the developer , but it works

Downloads - AllStarLink Wiki says that it runs under Debian 10. I have my hub node (hosted on a Linode VPS) running perfectly on Debian 10. It also runs DVSwitch stuff on it as well for Analog->DMR and Analog->P25 bridging. No issues.

I simply installed a vanilla version of Debian 10 and followed the instructions located at:

ASL 2.0 beta runs fine on Raspbian 10 (which I believe is Debian 10 repackaged for the Pi).

So, I am not sure where you are saying that Debian 10 doesn’t work as indicated by the developer.

The dev team has lives outside of allstarlink and they volunteer their time to make things better. They have families, full time jobs, etc. Sadly, I think this fact is overlooked way too many times. If you are in a hurry for Debian 11 support, you are welcome to volunteer with the team and help make it a reality.

Jim, K6JWN

How long ago did you install it, because with the current updates of the operating systems, there is no manual or procedure that has worked for me in vps or raspberry, and whoever doubts it, should try to perform a clean installation so that they realize, On the other hand, with the raspberry image with debian Buster 10, if I managed it, it would work perfectly even with a link to dmr

My VPS was created from a blank install of Debian 10 back on November 19th, 2021. I created a 2nd install from a blank install of Debian 10 for another hub a month later in December of 2021.

Jim, K6JWN

well , unfortunately I do not have the same luck , with , and I have no doubt that the procedures have worked for many , but at present I can not manage to install without error or that when I finish configuring it works without error , the only way is to run from raspberry with the allstar preinstalled image, it accepts that I add dvswitch and everything works without error, but on vps or installing by line by command line it does not work, it would be good to verify because with the current updates it is not possible to install !!!
I share the result image with the installation steps that are on the wiki

The only difference between what I am running and you are is that I am running a 4.9 kernel, looks like you are compiling into a 5.10 series kernel. Not sure if that is the cause of your issues.

Jim, K6JWN

It is possible that it is the cause , that is what I mean that currently I can not install , and tried with vps on old operating systems , but they are still updated and something always gives an error or does not find the libraries , that is why my suggestion to add the versions of necessary libraries and files to github

You have deb 11 installed.

Beta intended to work under deb 10 and will. I have one on a vps as well with DVS server.

The packages are maintained by volunteers, and no they probably aren’t up to date. You will have to hold your kernel version back to the one they used to build if you want the asl-dahdi-linux package to work. This is why the pre-made raspberry pi images work, because they use the same kernel the packages were built on.
I assume the above will work, although I did not try it because I went for the other option, which is to build from source. The dahdi code will need to be patched for kernel versions 5.9 and later. (see I am running on 64-bit Raspberry Pi OS, so basically Debian 11 with kernel 5.10. But this was only possible because I built everything from source. The repo packages won’t help here.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.