Allstarlink boot up issue on PI

Hi All,

I’ve had ASL up and running in a Pi4 with no issues for a few months. Last week I was unable to boot the pi up past the full rainbow screen. I assumed it to be a SD card issue, and as I had neglected to make a copy, wrote a fresh card (MD5 code checked out ok), same issue though, boot up hangs up on the rainbow screen. I’ve also tried running the ASL card on a Zero W with the same result. Pi4 and Zero both run Pi OS cards fine - I’ve also written new Pi OS cards which also run ok.

I’ve tried with:

The self extracting V1.7-01 and the xz file (MD5 codes always check out fine after extracting prior to writing to card).
3 different PCs / laptops
Rasp Pi Imager, win32discimager, balena etcher
numerous brand new SD cards (I only use Sandisk Extreme)
various USB card readers and SD card adaptors
power supply for Pi is the official Pi one

Pi specs I’ve tried on are:
Pi4 B REV1 and Zero W REV1 - firmware on both are up to date.

Has anyone had similar and have any guidance please?


What image are you putting on the SD card exactly ?

Hi Mike,

Thanks for your message - I’m writing the extracted V1.7 img file

Are you working with hamvoip ? I don’t recognize that by asl version/name.

we have asl 1.01 and 2.0b6 for the Pi
or perhaps you can explain further where you got said v1.7 Pi image

The download page on Hamvoip lists V1.7-01

I believe hamvoip has support groups at