Allstar Audio Archive Quality

I’m just setting up the archive audio setting to an external USB drive. This works fine and is storing .wav files in the directory.

The issue I seem to have is that the audio quality is poor and the files are very small. Is there a way to change the quality of the recording for the archives so it is more like that heard on DVswitch or directly when on the air ?

Any help much appreciated.


I use archive audio a good bit and always for me it is identical to when it was live.

are you converting it in any manor ?

the format is kinda a GSM or wav49 “.WAV” not fully MS .wav as asterisk denotes the difference.

I might also ask how you are playing it back ? on what device/manor.

Asterisk will play the file back 100% the same. No degradation. Some players may not be capable of noticing the difference or have the exact capability to do so. It is a bit odd and old.

Hi Mike,

I can link to an example file. The files just seem to be compressed sounding.

I did use Sox to convert the files into one file as that is my intention. However, when I’ve listened to hubnet , for example , their listen again audio sounds identical to how it sounds on the radio / DVswitch. Yet my audio sounds really low quality for some reason or other.

I can’t figure out if it is how the audio is being saved. Do I need to put GSM or wav as the option under the file type ? I did try putting pcm but it created larger files but I couldn’t convert them to a playable audio format. Sox just gave me a distorted audio output.

Is an example of the Sox converting multiple audio files to a single file.

I’m wondering if it is because I’m using the hamvoip version rather than allstarlink version? I doubt that’ll make any difference.

I wonder what others use as their settings in the rpt.conf whether I need to generate a raw file and convert it.

I’m guessing the output sample rate is 8000 and mono. 16bit?

An 11 minute file when stitched together is about 1.1mb I would have thought it would have been much larger.

Well, I can’t speak to any dif with hamvoip.

Since you are doing a combine of files, likely it is not recognizing the format correctly at the start.

Perhaps if you resample this in process of the combine ?
Likely it is treating it as a MS wav file, which it is not.

it is a 16b single channel 8k, so not all that big anyway, but I guess that depends on what you compare it to.

I probably did not mention this,
but a asterisk .WAV file is gsm compressed.

So make sure you are taking that into account when converting or combining.

You might try this in audicity to help you figure out where things are going wrong.

Hey Mike,

Turns out I need to use pcm audio and convert it to wav and then convert it to say mp3.

I think that has sorted it out. :+1:t2:

1 Like

For the record,
The format is (asterisk .WAV)

Audio PCM uncompressed 16bit 8khz mono(1 channel)

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.