Allmon3 v1.0.1 Released

Allmon3 v1.0 is now ready for public release. Allmon is the standard web-based monitoring and management for the AllStarLink application. Allmon3 is the next generation of the venerable Allmon2 that is rewritten for performance, scalability, and responsiveness.

Allmon3 v1.0.1 has been released to GitHub. Allmon3 v1.0.0 was never formally announced due to a late-breaking silent crashing problem that has now been resolved. Version 1.0.1 is configuration-compatible with the last announced version 0.11.6 and supported on Debian 12, 11, and 10 and should upgrade in-place with no issues.

Installation and configuration may be found in the README.md.

1 Like

Very well done!

Our upgrade from the previous stable release (0.11.6) had only one issue (that wasn’t related to allmon). Our server didn’t have the root certificates installed and Allmon couldn’t pull the database from the online server. Don’t know why I didn’t have this issue in the previous version.

If anyone is reading this and is having certificate issues (which you can see by checling “systemctl status allmon3” ), its a pretty easy fix. Install the CA certificates and refresh them. Here are the commands (working on Debian 10, Allstarlink 2.0 beta 6 flashed image on an rpi)

sudo apt install ca-certificates
sudo update-ca-certificates --fresh
systemctl restart allmon3

Thanks for your hard work!

1 Like

Our server didn’t have the root certificates installed and Allmon couldn’t pull the database from the online server. Don’t know why I didn’t have this issue in the previous version.

Version 1.0.x switched to using TLS/HTTPS everywhere. Previously the database was downloaded over HTTP.

Very well done!

Thanks! Glad you’re enjoying it.

Can it be installed on a Raspberry Pi?
Tried following the steps on GitHub but they didn’t work.

@Alex_Dominguez you’d have to be more specific. It works just fine on a number of platforms including Raspberry Pis but it depends on what OS you’re running, etc. Can you provide details of your issue?

Tried installing it, gave me an error that dirmng was not found. installed dirmngr and then it gave me another error that another thing was version 1.3.3 and needed version 1…3.4 but the update only finds the same old version 1.3.3 so I cant even pass the key installation. Running the latest version of allstar on a Raspberry Pi 3B+

1 Like

Decided to revisit this and give it another go-
Still have install errors on Raspbian Buster- in dependency steps- (all prior steps ok under " Install Debian 10 / Raspian 10 Software")

“apt install -y -t buster-backports python3-async-timeout python3-attr python3-multidict python3-yarl python-pip3
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package python-pip3”

I have been using Allscan as my main interface for the stats/activity and easy to see and use favs list and control.

Can you clarify which version you mean by “latest version”?

I believe that’s an error in the Debian 10 directions. Change that to python3-pip and try that same command again.

That fixed install thx- and I got the web page to load but something went wrong in cfg maybe. Now I get “SEVERE: Could not contact the allmon3 manager. Check the allmon3 service, webserver config, and reload the window.”

I searched forums and tried some steps Tim suggested:
" First thing to work on is getting the Allmon3 service to login to the Asterisk Manager.

  • Edit the /etc/allmon3/allmon3.ini file and set the user ID and password to match the user ID and password in /etc/asterisk/manager.ini
  • Restart the service. As root to sudo: systemctl restart allmon3.service
  • Check that the service is running w/o errors. As root to sudo: systemctl status allmon3.service"

I saw errors when looking at status:

  • allmon3.service - Allmon3 daemon
    Loaded: loaded (/lib/systemd/system/allmon3.service; enabled; vendor preset: enabled)
    Active: failed (Result: exit-code) since Tue 2024-03-05 01:40:22 PST; 1min 15s ago
    Process: 3609 ExecStart=/usr/bin/allmon3 (code=exited, status=1/FAILURE)
    Main PID: 3609 (code=exited, status=1/FAILURE)

Mar 05 01:40:21 Pi-ASL-48654 allmon3[3609]: node_configuration = node_configs.NodeConfigs(config_fil
Mar 05 01:40:21 Pi-ASL-48654 allmon3[3609]: File "/usr/lib/python3/dist-packages/asl_allmon/node_confi
Mar 05 01:40:21 Pi-ASL-48654 allmon3[3609]: config_full.read(config_file)
Mar 05 01:40:21 Pi-ASL-48654 allmon3[3609]: File “/usr/lib/python3.7/configparser.py”, line 696, in re
Mar 05 01:40:21 Pi-ASL-48654 allmon3[3609]: self._read(fp, filename)
Mar 05 01:40:21 Pi-ASL-48654 allmon3[3609]: File “/usr/lib/python3.7/configparser.py”, line 1065, in _
Mar 05 01:40:21 Pi-ASL-48654 allmon3[3609]: lineno)
Mar 05 01:40:21 Pi-ASL-48654 allmon3[3609]: configparser.DuplicateSectionError: While reading from '/etc
Mar 05 01:40:22 Pi-ASL-48654 systemd[1]: allmon3.service: Main process exited, code=exited, status=1/FAI
Mar 05 01:40:22 Pi-ASL-48654 systemd[1]: allmon3.service: Failed with result ‘exit-code’.
~

and errors in debug output:

root@Pi-ASL-48654:/home/repeater# allmon3 --debug
DEBUG: (allmon3) config file is /etc/allmon3/allmon3.ini
Traceback (most recent call last):
File “/usr/bin/allmon3”, line 231, in
raise e
File “/usr/bin/allmon3”, line 189, in
node_configuration = node_configs.NodeConfigs(config_file, filter_list)
File “/usr/lib/python3/dist-packages/asl_allmon/node_configs/init.py”, line 21, in init
config_full.read(config_file)
File “/usr/lib/python3.7/configparser.py”, line 696, in read
self._read(fp, filename)
File “/usr/lib/python3.7/configparser.py”, line 1079, in _read
raise MissingSectionHeaderError(fpname, lineno, line)
configparser.MissingSectionHeaderError: File contains no section headers.
file: ‘/etc/allmon3/allmon3.ini’, line: 11
‘host = 127.0.0.1 # (R) DNS name or IP address of the Asterisk/ASL node\n’
root@Pi-ASL-48654:/home/repeater#

That error means that you have either broken the file or put something in it that is unparsable. Can you strip out the passwords and post it here? or better yet file an issue on Github?

“file an issue on Github”
done- thx

Hello. How to configure Allmon3 to be accessible from the external internet connection? I need to remotely monitoring my node and be able to disconnect users.

Can you be more specific? A default install is Internet ready.

This is my allmon3.ini configuration:

[61067]
host=0.0.0.0
port=5038
user=admin
pass=Somepassword

And i able to access Almon3 web page only throw LAN. When I try to open it throw the WEB, I type my static IP address (for example, 33.134.96.50/allmon3) and it wants open. What should I change in setup file, and what port should I forwarding in my router?

You do not need to change anything with Allmon3. You can forward any port your want from your router to the Node host on port 80. If you’re not using port 80 already as a forward, then you can simply forward port 80 to port 80.

For example, if your internal router is 192.0.2.1 and your AllStar node is 192.0.2.5, then port forward 80 in your router to 192.0.2.5 port 80. However your Internet provider may block port 80 and then you can use whatever port your want such as 8000. Then you go browse to http://33.134.96.50:8000/allmon3 in that example.

Wow, it’s that simple and actually work! Thank you!

A new problem appeared. After movign node to another internet provider, wen open allmon page, even locally, I got a mesage “SEVERE: Could not contact the allmon3 manager. Check the allmon3 service, webserver config, and reload the window.” and allmon3 page without list of connected nodes, just home button, Allstarlink logo and Allmon v3 1.2.0