Allmon 3 not show connections. Error: SEVERE: Could not contact the allmon3 manager

Hello. I need some help. After moving node to another internet provider, when open Allmon page, even locally, I got a message “SEVERE: Could not contact the allmon3 manager. Check the allmon3 service, web server config, and reload the window.” and allmon3 page without list of connected nodes, just home button, Allstarlink logo and Allmon v3 1.2.0

What moved? The node, Allmon or both?

Take a look at the logs… sudo journalctl -u allmon3.service -f

A node with installed Allmon 3 was moved from one ISP to another. Where on previous ISP Allmon work as intended, on the new location get an error.
Log: May 26 17:56:08 repeater allmon3[501]: ERROR: (asl_allmon.allmon3_ws_status) No connection for on 16700 due to unreachable AMI - waiting 15 seconds

With both Allmon3 and Allstar on the same server a move to a new IP address should just work.

Do the last few lines of /etc/allmon3/allmon3.ini look similar to:


Of course the user and password have to match the ones in /etc/asterisk/manager.ini

There is no manager.ini, only manager.conf, and passwords in allmon3.ini and manager.conf are match
Log output after I reboot the node

May 26 21:21:26 repeater allmon3[507]: INFO: (asl_allmon.web_configs) Binding sevices to all addresses
May 26 21:21:26 repeater allmon3[507]: INFO: (allmon3) no %s found; no menu data available
May 26 21:21:26 repeater allmon3[507]: INFO: (allmon3) starting status ws 1997@ on port 16700
May 26 21:21:26 repeater allmon3[507]: INFO: (allmon3) starting cmd ws 1997@ on port 16701
May 26 21:21:26 repeater allmon3[507]: INFO: (allmon3) starting allmon3 master ws on port 16080
May 26 21:21:26 repeater allmon3[507]: INFO: (allmon3) starting node_db updater
May 26 21:21:26 repeater allmon3[507]: INFO: (asl_allmon.node_db) Retrieving database from
May 26 21:21:26 repeater allmon3[507]: INFO: (asl_allmon.allmon3_ws_status) broadcasting status for 1997 on port 16700
May 26 21:21:29 repeater allmon3[507]: INFO: (asl_allmon.node_db) Updated node database in 2.73 seconds
May 26 21:21:29 repeater allmon3[507]: INFO: (asl_allmon.node_db) populated AllStarlink database

My bad, manager.conf is correct. Are you really using node number 1997?

Yes, it’s correct. My private node number is 1997, as setup in rpt.conf

Based on that log, it looks like that your trouble is in your webserver configuration. Can you paste in your Apache or Nginx configuration?

Where can I find Apach configuration? As I understand, Apache is the default webserver for Allmon3.

Look at /etc/apache2/conf-available/allmon3.conf and /etc/apache2/sites-available/default.conf

## Configuration for the allmon3 application

Alias /allmon3 /usr/share/allmon3

<Directory /usr/share/allmon3>
	AllowOverride all

    # Implement rewrite within the directory so that is survives
    # into the <VirtualHost> tags
    RewriteEngine On
    RewriteCond %{HTTP:Upgrade} =websocket [NC]
    RewriteRule ^ws/([0-9]+) ws://localhost:$1 [P,L,QSA]

# Proxy can't usefully occur inside a <Directory> on Debian
ProxyAddHeaders On
ProxyPreserveHost On
ProxyPass /allmon3/master/ "http://localhost:16080/"

In directory sites-available there are only two files: 000-default.conf and default-ssl.conf


<VirtualHost *:80>
	# The ServerName directive sets the request scheme, hostname and port that
	# the server uses to identify itself. This is used when creating
	# redirection URLs. In the context of virtual hosts, the ServerName
	# specifies what hostname must appear in the request's Host: header to
	# match this virtual host. For the default virtual host (this file) this
	# value is not decisive as it is used as a last resort host regardless.
	# However, you must set it for any further virtual host explicitly.

	ServerAdmin webmaster@localhost
	DocumentRoot /var/www/html

	# Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
	# error, crit, alert, emerg.
	# It is also possible to configure the loglevel for particular
	# modules, e.g.
	#LogLevel info ssl:warn

	ErrorLog ${APACHE_LOG_DIR}/error.log
	CustomLog ${APACHE_LOG_DIR}/access.log combined

	# For most configuration files from conf-available/, which are
	# enabled or disabled at a global level, it is possible to
	# include a line for only one particular virtual host. For example the
	# following line enables the CGI configuration for this host only
	# after it has been globally disabled with "a2disconf".
	#Include conf-available/serve-cgi-bin.conf

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

Interesting. That all looks correct. Is this a public-facing server that I can connect to the web interface on?

I’m not quite understand the question. All I can tell, that at the beginning, I was able to open Allmon3 throw LAN or WEB, and see all connected devices (it was generally another private node and DVSwitch clients). And after I change my ISP, I still can open Allmon3 throw LAN or WEB, but get this error message and no list of connected nodes.
P.S. My setup is Raspberry Pi3 B+ with Allstar 2.0 beta, Allmon3, and half duplex transceiver, connected through the wi-fi to router with static external IP address and all necessary ports forwarded.

Is there a URL I can visit to see your system?

I send you a private message with address. Is there are any other information I can provide to resolve my problem?

So this appears to be a configuration error with your Pi and not Allmon3. If you connect to (replacing that with your IP address), you will see the error. Your Pi doesn’t know what ‘localhost’ is. Presumably this means that your /etc/hosts file on the Pi is messed up. You should have something that looks like the following

$ cat /etc/hosts       localhost
::1             localhost ip6-localhost ip6-loopback
ff02::1         ip6-allnodes
ff02::2         ip6-allrouters       node48496

Where is the name you’ve given the Pi itself.

Thank you very much for youre help! Youre solution was top notch, everything is working now.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.