A Baofeng, an Easy Digi and a RPi 3B+ walk into a bar

…so far no one has left happy.

I have recently tried to put together an AllStarLink node as another project to complete. I’ve had no issues using these three for various other setups. However, AllStar image does not seem to like what I have. I’ve been able to use this setup to send winlink emails, I’ve done APRS, I’ve done SvxLink server with it as well. However, when it comes to AllStar I’m getting no love.

What I’m trying to accomplish is using allstarlink to trigger gpio pin on the pi which in turn triggers the easy digi to activate the PTT on the radio. I’m using a Sabrant USB card. Now I’ve done a bit of searching and googling and not finding anything. I think there is a whole 1 or 2 times Easy Digi has been mentioned on here. The USB I know is not a CM1XX soundcard. I do see that running lsusb does show the sound card with no issues. I tried to use the simpleusb-tune-menu but when I go to option 2 to set voice level it comes back saying usb_55153 is not currently active. If I try to do option S it says that this option 4 has failed.

I did originally tried loading up HamVOIP and that was able to get further but I wanted to try the official AllStarLink image first to get a node up and running. Will my setup not ever work with AllStar due to the fact I wanna use GPIO on the Pi and my soundcards not CM1XX? If so I find that pretty disappointing and limiting to the software. Any input is appreciated.

The radio tune function was written specifically for the cm1xx
Using anything else will likely get unexpected response.

1 Like

The usb channel looks for specific vendor ID’s - if it does not find one it likes, then it won’t work. If you can get the audio to work, however, I believe there is a way to use other IO for PTT control.

1 Like

Jim Dixon’s SIP and resulting original AllStar code is open source. Derivative audio and control I/O code interfaces evolved with community contribution, having determined that the CM108 and following had the quality and consistency of audio and USB I/O interface suitable to compliment that high-quality code that embraced it. Clones/alternatives to the CM108 and subsequent, are maybe merely just that or less… sort of like the Prolific vs. FTDI USB-serial interface debacle (another detailed story about actual legit device drivers vs Prolific mucking up Windows PCs…)

So, here exists an opportunity to foster, recruit, contribute to a larger hardware support base if an optional, consistent, reliable, high-quality USB sound + I/O interface exists… perhaps starting with opening up the USB audio dongle thingy you want to have work and identifying the chip, if possible… possible perhaps one or either or both of two ways…

Actual markings on the internal chip - if it’s not merely some obscure chip-on-board over-coated blob. Inserting the USB device into a Windows PC and using Device Manager to get the universal PnP hardware ID details, or similar if inserted into a Pi and grabbing the device ID data from the ‘lsusb’ command.

Practically, writing code around some obscure xxx-cloned device is not what one wants to depend on when insisting against preclusive hardware selection criteria. Whatever part is inside your sound dongle may not have any documentation, or ceased to be available on the mass/hack/Amazon/eBay market 3 years ago, never to be visited again, much less supported long-term.

Otherwise…

There is a specific reason the SIP/AllStar software evolved and determined that the native on-board Pi audio interface was not appropriate - it requires significant OS/CPU processing time and lesser quality than the CM108/109 chip, so it is best to offload that generic function to hardware/firmware vs chewing up limited Pi CPU performance.

Conversely, awkwardly-limited low-speed ‘digi’-mode bits at rates allowed/accommodated via amateur radio bandwidth, etc., FT8, JTxx, etc. are ‘easy’ to process in low-performance hardware. Those are akin to 300-, 1200-baud modems that were all we had for dial-up pre-Interwebs. Have you ever tried to implement TCP/IP protocols and effective work-product at 300, 1200, 2400, 9600, 14.4, 19.2, 38… 56k analog modem rates? No? Lucky you. Half of those rates are what amateur radio is limited to in 90% of the spectrum we have the privilege to operate within.

Looking forward to your contribution of specific Device ID information, preferably links ot datasheets from the device manufacturer, and even better, someone, you? capable and willing to dive-into obscure device-specific I/O coding support to expand the SIP/AllStar universe.

Thanks for posting…

Thanks for the replies. Though the last one comes off heavily dripping in sarcasm. I’m not stating that the software should support everything, it was just a question of will it work or not if not than ok. However if you were seriously asking then heres some information. This is the Sabrant USB soundcard that I’ve seen used by lots of the hams on youtube and in their store. Here is a link to the product page.

According to lsusb it shows up as a C-Media Electronics, Inc. Audio Adapter (Unitek Y-247A) I’ve attached a picture of a chip found within the card. I have also found the link to the dataheet which is located here. https://datasheet.lcsc.com/szlcsc/1906061502_Cmedia-HS-100B_C371351.pdf

Unfortunately I have never wrote a driver or know how to. If I knew how to I would. If there is anything more you’d like to know I could look into it.

The audio worked when manually triggering COS in the HamVOIP. Not within AllStar. So I’m not sure why it did in one and not the other. I know they are 2 different things but I thought they were based on a lot of similar backend. Again i don’t know I didn’t go looking at the code. Just was curious.

This part seems not to have any GPIO which is required for PTT COR etc. So it’s not a good choice.

Ken

I don’t need the soundcard to have GPIO as I’d like to use the GPIO on the pi to control the PTT. Same way direwolf can use the pin to trigger the Easy Digi for PTT as well as SvxLink can as well. Incoming audio is using vox I believe.

Just suggesting that missing feature is one reason is why this chip would not be supported in the base software.

Check duplex mode in simpleusb/radiousb

Tried that but no matter what it just errors.