# Suddenly registration is failing - no changes

**URL:** <https://community.allstarlink.org/t/suddenly-registration-is-failing-no-changes/23315>\
**Category:** Archive\
**Created:** [May 28, 2025, 6:23pm UTC](https://community.allstarlink.org/t/suddenly-registration-is-failing-no-changes/23315 "2025-05-28T18:23:11Z")\
**Posts on this page:** 14\
**Page:** 1

<div class="post-metadata">

**Author:** ![VE3SJA](https://community.allstarlink.org/letter_avatar_proxy/v4/letter/v/5daacb/32.png) [@VE3SJA](https://community.allstarlink.org/u/VE3SJA)\
**Post date:** [May 28, 2025, 6:23pm UTC](https://community.allstarlink.org/t/suddenly-registration-is-failing-no-changes/23315/1 "2025-05-28T18:23:11Z")

</div>

Hi fellow HAMs !! I have been using my  
Allstar node from my raspberry pi 3 and a Shari device for months , and it has worked flawlessly. For the past few days , I am not able to connect to any nodes. It keeps saying the registration is timing out. I contacted the help desk and they said they’re has been registration server issues as of late, but they don’t take care of that and I should post here and “someone will look into it” .. nothing in the config or network has changed, and I feel like this a backend issue and requires someone with admin access to fix. I have tried alternate registration servers and can ping them just fine, but they keep saying “timed out” and it won’t register. I really miss having this connection, can somebody help ? I’ve done all I can to fix it from here. I see there is an IAX registry workaround, and I’m wondering if I should try that. It says not unless you have to , but I have no other way to connect at the moment . Any advice or someone else I can email on this issue ? Thanks …

---

<div class="post-metadata">

**Author:** ![Chuck](https://community.allstarlink.org/user_avatar/community.allstarlink.org/chuck/32/3682_2.png) [@Chuck](https://community.allstarlink.org/u/Chuck)\
**Post date:** [May 28, 2025, 9:59pm UTC](https://community.allstarlink.org/t/suddenly-registration-is-failing-no-changes/23315/2 "2025-05-28T21:59:11Z")

</div>

There was a ~24 hr issue with one of the two registration servers 6 days ago, but I've seen nothing since. The devs will see your post; they'll have more info.

---

<div class="post-metadata">

**Author:** ![N8EI](https://community.allstarlink.org/user_avatar/community.allstarlink.org/n8ei/32/4254_2.png) [@N8EI](https://community.allstarlink.org/u/N8EI)\
**Post date:** [May 28, 2025, 11:19pm UTC](https://community.allstarlink.org/t/suddenly-registration-is-failing-no-changes/23315/3 "2025-05-28T23:19:00Z")

</div>

There was a problem with registration servers on the evening of Friday May 23rd into mid-morning Saturday May 24th ET. That has been resolved and there are no issues reported since. Can you please provide any logging output or details of what is saying it's "timed out"?

---

<div class="post-metadata">

**Author:** ![Chuck\_Henderson](https://community.allstarlink.org/letter_avatar_proxy/v4/letter/c/ba9def/32.png) [@Chuck\_Henderson](https://community.allstarlink.org/u/Chuck_Henderson)\
**Post date:** [May 29, 2025, 3:17am UTC](https://community.allstarlink.org/t/suddenly-registration-is-failing-no-changes/23315/4 "2025-05-29T03:17:55Z")

</div>

Did you try rebooting your raspberry pi since the registration server problem was fixed?

---

<div class="post-metadata">

**Author:** ![VE3SJA](https://community.allstarlink.org/letter_avatar_proxy/v4/letter/v/5daacb/32.png) [@VE3SJA](https://community.allstarlink.org/u/VE3SJA)\
**Post date:** [May 29, 2025, 2:07pm UTC](https://community.allstarlink.org/t/suddenly-registration-is-failing-no-changes/23315/5 "2025-05-29T14:07:24Z")

</div>

Thanks so much for the reply, I really appreciate the help, I am able to ping both registration servers (the main one and I tried west) and the return from the ping is fine, but it gives me this :

 ![IMG_3788](https://community.allstarlink.org/uploads/default/original/2X/1/1b8685cb608b74516028195ff01ca01ca70ee71f.jpeg)

And the web portal , node settings … it says Registered “No” , so I don’t imagine anything will connect just from that. But this account has been working just fine for months, I don’t know why that suddenly changed to not registered. I had tried changing to password to see if that fixed it but no luck there , and I have reverted it to the original one. All passwords Match in the iax.conf . I’m not the most computer savvy operator out there, so if there is somerhing specific or output from something that would help please let me know . The pi has been rebooted several times and that’s not the fix apparently. When I re-run the show registry command , state changes to “request sent” for a few and then change back to “timeout” (it will only let new users post 1 pic) .. Thanks again !!

---

<div class="post-metadata">

**Author:** ![N8EI](https://community.allstarlink.org/user_avatar/community.allstarlink.org/n8ei/32/4254_2.png) [@N8EI](https://community.allstarlink.org/u/N8EI)\
**Post date:** [May 29, 2025, 5:35pm UTC](https://community.allstarlink.org/t/suddenly-registration-is-failing-no-changes/23315/6 "2025-05-29T17:35:24Z")

</div>

Looking at the database and the logs, it's not failing registration so much as your node doesn't seem to be trying to register at all. There's no attempt for node 60824 to register since it's last successful registration on 2025-05-24 18:40 UTC which is well after the problem with register-central. From your screenshot, it looks like you're using HamVOIP which has a grafted-in parallel system so that could be the problem? I can't help with HamVOIP.

---

<div class="post-metadata">

**Author:** ![VE3SJA](https://community.allstarlink.org/letter_avatar_proxy/v4/letter/v/5daacb/32.png) [@VE3SJA](https://community.allstarlink.org/u/VE3SJA)\
**Post date:** [May 29, 2025, 9:26pm UTC](https://community.allstarlink.org/t/suddenly-registration-is-failing-no-changes/23315/7 "2025-05-29T21:26:40Z")

</div>

Thanks very much for looking into that, it’s appreciated! ‘73

---

<div class="post-metadata">

**Author:** ![KX4ZU-Tim](https://community.allstarlink.org/letter_avatar_proxy/v4/letter/k/6f9a4e/32.png) [@KX4ZU-Tim](https://community.allstarlink.org/u/KX4ZU-Tim)\
**Post date:** [December 8, 2025, 1:42am UTC](https://community.allstarlink.org/t/suddenly-registration-is-failing-no-changes/23315/8 "2025-12-08T01:42:38Z")

</div>

I have recently run into the same problem. I have a HamVOIP node (532526) that has worked for YEARS. When I login to the AllStarLink website, the 532526 node shows as NOT REGISTERED. Nothing has changed on my node. I have rebooted it and restarted Asterisk multiple times. When I issue the “iax2 show registry”, I see the following:

pi400-532526\*CLI\> iax2 show registry  
Host dnsmgr Username Perceived Refresh State  
52.20.63.146:4569 Y 532526#4566 60 Request Sent

After a few minutes, I see the following:

52.20.63.146:4569 Y 532526#4566 60 Timeout

I can connect to the node and use it to connect to SOME nodes like Parrot Nodes and 552990 for example. However, there a some nodes like 505422 and 27339 that I cannot connect to. I assume these failed connections are due to my node not showing as registered.

Since nothing that I am aware of has changed on my node, I can only assume it has something to do with the Allstar registration servers.

Any guidance on how to get my node to register will be much appreciated.

Tim

KX4ZU

---

<div class="post-metadata">

**Author:** ![N2DYI](https://community.allstarlink.org/user_avatar/community.allstarlink.org/n2dyi/32/1712_2.png) [@N2DYI](https://community.allstarlink.org/u/N2DYI)\
**Post date:** [December 8, 2025, 3:16am UTC](https://community.allstarlink.org/t/suddenly-registration-is-failing-no-changes/23315/9 "2025-12-08T03:16:31Z")

</div>

Look in /etc/asterisk/iax.conf.

Does your registration line for the node include “#4566”? If so, delete #4566 from that line, save it, then reload or restart Asterisk.

The more modern registration server doesn’t like that anymore, and there were some old instructions from years ago that had people include the port in the registration line. This no longer applies, and you’ll not have that even be a possibility if you use ASL3 with HTTP registration.

---

<div class="post-metadata">

**Author:** ![KX4ZU-Tim](https://community.allstarlink.org/letter_avatar_proxy/v4/letter/k/6f9a4e/32.png) [@KX4ZU-Tim](https://community.allstarlink.org/u/KX4ZU-Tim)\
**Post date:** [December 8, 2025, 3:27am UTC](https://community.allstarlink.org/t/suddenly-registration-is-failing-no-changes/23315/10 "2025-12-08T03:27:31Z")

</div>

WOOHOO!!! That did the trick. Thank you so much for letting me know about this change.

Thanks again!

Have a Happy Holiday!

---

<div class="post-metadata">

**Author:** ![N8EI](https://community.allstarlink.org/user_avatar/community.allstarlink.org/n8ei/32/4254_2.png) [@N8EI](https://community.allstarlink.org/u/N8EI)\
**Post date:** [December 8, 2025, 1:15pm UTC](https://community.allstarlink.org/t/suddenly-registration-is-failing-no-changes/23315/11 "2025-12-08T13:15:34Z")

</div>

> [@N2DYI](#):
>
> The more modern registration server doesn’t like that anymore, and there were some old instructions from years ago that had people include the port in the registration line.

Do you have a URL for such directions? I've never seen that and it never came up since I deployed the new IAX auth servers back in September. The IAX registration system was completely rewritten for performance reasons and does strict string sanitization to fix other problems. If there was something in the code that worked with a `#PORT` designator it was completely unintentional in the old code.

---

<div class="post-metadata">

**Author:** ![N2DYI](https://community.allstarlink.org/user_avatar/community.allstarlink.org/n2dyi/32/1712_2.png) [@N2DYI](https://community.allstarlink.org/u/N2DYI)\
**Post date:** [December 8, 2025, 8:49pm UTC](https://community.allstarlink.org/t/suddenly-registration-is-failing-no-changes/23315/12 "2025-12-08T20:49:06Z")

</div>

Unfortunately, I can’t find it now, but I know that HamVoIP had people do this for a while, because I also had a couple of old nodes with that problem show up around maybe September 20 or so. Don’t remember the exact date, and that was the cause. I definitely remember seeing reference to it in either one of the HamVoIP howtos, or on the now defunct HamVoIP email reflector.

---

<div class="post-metadata">

**Author:** ![Greg\_Pritchett](https://community.allstarlink.org/user_avatar/community.allstarlink.org/greg_pritchett/32/4561_2.png) [@Greg\_Pritchett](https://community.allstarlink.org/u/Greg_Pritchett)\
**Post date:** [December 18, 2025, 3:03am UTC](https://community.allstarlink.org/t/suddenly-registration-is-failing-no-changes/23315/13 "2025-12-18T03:03:21Z")

</div>

My node suddenly stopped connecting to ASL only nodes. It still connects to nodes also registered to Hamvoip. I checked the registration line doesn't have the port number in it for the Allstar registration. It is in the Hamvoip registration line.

---

<div class="post-metadata">

**Author:** ![N8EI](https://community.allstarlink.org/user_avatar/community.allstarlink.org/n8ei/32/4254_2.png) [@N8EI](https://community.allstarlink.org/u/N8EI)\
**Post date:** [December 18, 2025, 3:44am UTC](https://community.allstarlink.org/t/suddenly-registration-is-failing-no-changes/23315/14 "2025-12-18T03:44:49Z")

</div>

You'd need to provide more information such as a node number and configuration example.
