Successful install of AMD ASL 1.01...My Journey

I started with a Zotac Mini-PC and a Blank 8GB SSD. I downloaded the ’ ASL_1.01-20180417-amd64-i386-debian-stretch-netinst.iso ’ iso image. When I tried to write the ISO to a CD using NERO, the image was too large for a CD. NERO would not let me write this CD image to a DVD. I did some research, and found a free program called ’ RUFUS ’ to write the ISO to a flash drive. Now to the ZOTAC. I booted on the flashdrive, and got a graphical page with some options for installing, and close ’ Install '. This seemed to do an install to the SSD. When I rebooted on the SSD, I had Debian 9 installed, but NO ASL? I removed the SSD, deleted the partition on another PC using Diskpart, and tried again to install from the flashdrive on the Zotac. Same result, I had Debian 9 but NO ASL? I again removed the SSD partition. This time, I reformatted the flash drive, and rewrote the ISO image with RUFUS. Back to the Zotac. This time, when I booted on the flashdrive, I got a different install menu with options to install ASL…AhHa! When I tried to install, it failed with a error about items not found? After some trial and error, I discovered I had to create a new partition on the SSD, and format it with FAT32. Then the install of ASL was successful. I have no idea why I was getting the wrong install menu at first. Hope this long explanation helps some people. Len, WB2HKK.