Recompiling from the Source Code

Hello All,

I’m running DIAL 64-bit, and I’m going a bit old school to the “ACID Days”, and want to make some tweaks to the source code to make a few scripts work. So…

I did a clean install from ASL_1.01-20180417-amd64-i386-debian-stretch-netinst.iso

I believe I have all the Prerequisites installed:
apt-get install git git-core
apt-get install g+±4.9
apt-get install gcc-4.9
apt-get install libncurses5-dev

I’ve cloned the AllStarLink Repository cloned:
git clone https://github.com/AllStarLink/Asterisk.git
cd Asterisk/asterisk

The configure runs fine without errors:
./configure CXX=g+±4.9 CC=gcc-4.9

When I do a make command, I get:
menuselect/menuselect --check-deps menuselect.makeopts


  • The existing menuselect.makeopts file did not specify*

  • that ‘app_flash’ should not be included. However, either some*

  • dependencies for this module were not found or a*

  • conflict exists.*

  • Either run ‘make menuselect’ or remove the existing*

  • menuselect.makeopts file to resolve this issue.*


Makefile:330: recipe for target ‘menuselect.makeopts’ failed
make: *** [menuselect.makeopts] Error 255

I have tried a make clean then make and still get the same result.

Any ideas?

Thanks,
Monty
KE7JVX

Take a look at these scripts. I think you’re missing some packages.

https://github.com/AllStarLink/ASL-Install/blob/master/scripts/build_tools.sh

https://github.com/AllStarLink/ASL-Install/blob/master/scripts/required_libs.sh

Thanks!

I ran both scripts and a few packages installed, but I still am getting the same error on the menuselect. I did run a make clean as well.

It’s likely that menuselect.makedeps and menuselect.makeopts got clobbered by make clean. Try running the following:

make clean
git checkout menuselect.makedeps
git checkout menuselect.makeopts
./configure CXX=g++-4.9 CC=gcc-4.9
make

I just tried the commands you suggested, still getting the same error message after make command.

Those two git checkout commands should have restored the files to their previous state. Perhaps this didn’t occur. Check the contents of those two files against the ones in the repository. You can always wipe out the directory and do another git clone. Just don’t run make clean after the clone.

To install gcc 4.9 add these lines to your /etc/apt/sources.list:

# for gcc 4.9
deb http://ftp.us.debian.org/debian/ jessie main contrib non-free
deb-src http://ftp.us.debian.org/debian/ jessie main contrib non-free

Then do

apt-get update
apt-get install g++-4.9

Comment the added sources.list lines and apt-get update again.

if you have installed the dependencies, you’re good to go:

./configure CXX=g++-4.9 CC=gcc-4.9
make
make bininstall

Another Asterisk compile question for you gurus. I can make minor tweaks and recompile fine.
Would like to just play with some of the experimental channel drivers that support RPi GPIO.
KG7Qin ASL_GPIO https://github.com/KG7QIN/ASL_GPIO.git
Understand this not part of the official release, just want to play, experiment and may be learn something.
So what is the proper way to add new modules? I copied the C code into the channels directory of the source, replacing the ones that had identical names. It blows up at line 361 recipe for target main failed (or something to that effect)

Ed W8VT