Need help with Simpleusb-tune-menu

I’m setting up my first AllStarLink private node and I need some help with ALS Main Menu option 4 Run simpleusb-tune-menu for SimpleUSB configuration.
After entering that option I get the sub menus and I can select option 1 to pick the only USB device connected. When I run option 2 Set Rx Voice Level (using display) all I get is:
v – 3KHz v – 5KHz

What should I expect here? Should I be seeing several samples of the RX noise level and some final result? I can’t find any details on this in any of the setup documentation I’ve found online.
I’ve tried two different USB device. One is a pre-modified CM-119 based device and the other is a CM-108 based device. Both have the same results. When I connect to the server using DVSwitch Mobile I can PTT and transmit audio over the connected transceiver but I can never get any audio from the transceiver back to the DVSwitch Mobile app.

Thanks for any suggestions.

Chris J.

You should see an ASCII bar graph with received audio.

Technically you are supposed to use a service monitor to generate a full quieting signal with a 1kHz tone with 3kHz deviation and adjust the RX level to the 3kHz mark. This should be done with no CTCSS.

People who don’t have the gear for that can get close enough by setting voice peaks a bit above 5kHz.

If you are having problems getting no audio at all, start with making sure you have CTCSS off. Then invert USB COR if necessary.

I’m fortunate to have access to a very nice Aeroflex 3920 so generating the required signals for the setup is no issue and I’m not generating a CTCSS. The transceiver I’m working with as no discrete output for driving the COR input on the USB device so in usbradio.conf I have:
carrierfrom = vox
Is this something that should work in ASL 1.01?

As far as I know VOX should work but I’ve never tested it.

Is there RX audio on the correct input to the URI?

Yup, confirmed audio is getting to the correct pin on the USB device. I’ve tested that by using the same devices on a Windows laptop and using Audacity to confirm I can record and playback audio.

I guess what I can do is set carrierfrom = usbinvert and temporarily pull the COR line low by connecting it to the USB device ground and then test to see if RX audio is getting through.

If I’m using a CM-108 or CM-119 device what module should be loaded in modules.conf?
CM1xx USB Cards with Radio Interface Channel Driver (No DSP)
CM1xx USB Cards with Radio Interface Channel Driver (DSP)


load => is for use with simple-tune-menu.

load => is for radio-tune-menu

Be sure to select the correct rxchannel= in rpt.conf

rxchannel = dahdi/pseudo                ; No radio (hub)
; rxchannel = SimpleUSB/usb_1999        ; SimpleUSB
; rxchannel = Pi/1                      ; Raspberry Pi PiTA
; rxchannel = Radio/usb_1999            ; USBRadio (DSP)
; rxchannel = Dahdi/1                   ; PCI Quad card
; rxchannel = Beagle/1                  ; BeagleBoard
; rxchannel = USRP/; GNU Radio interface USRP

OK, I’ll check those settings as well, but just to be clear, in your last post it looks like rxchannel = dahdi/pseudo is the one that is not commented out, is that the one I want for use with the CM-108 or 119 USB device, or should I use rxchannel = SimpleUSB/usb_1999 instead of the dahdi/pseudo?

Yes, you should use that. Sorry for the confusion.

Do I need to change the _1999 to match my node number?

Opps, sorry. I answered my own question. Looks like that already matches my node number when I look in my rpt.conf file. Must have gotten set during the initial config.
I’ll do my troubleshooting with the COR discrete and see how things work out.

The _xxxx part doesn’t have to match your node number. It’s just a convention in case you end up having more than one usb device on your server. However, the usb_xxxx has to match the [usb_xxxx] stanza in simpleusb.conf.

OK, I found my problem. I was mistakenly changing options in usbradio.conf when I should have been in simpleusb.conf for the USB devices I’m using. There is no carrierfrom = vox option in simpleusb.conf. The only options in simpleusb.conf for carrierfrom = are; no, usb, and usbinvert. My test with carrierfrom = usbinvert and the COR line held low does allow my RX audio to be processed by ASL and heard at my DVSwitch Mobile app. I’ll just need to look into an external VOX circuit for my RX audio to drive the COR line on the USB device.

Thanks for your help.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.