Need help in setting up my node in RPi3B+

I have a node already but been absent in ham radio for 2 years. I have a RPi3B+ and a BF-888S for my node. Just completed modifying the radio and the soundcard. I have downloaded the asl-2.0.0-beta-4 and flashed it on a 16gb sd card. I was able to get into the configuration for the first time and followed the Beginners Guide and Allmon2 Setup. I faced a problem where it says $ chmod 777 astdb.php. It says no such file or directory. Also, when I login to the Allmon2 via the web browser, I get a login fail message. I did set my admin password via the htpasswd and also edited the manager.conf.

Is there a step by step instructions or a link to a video on how to set this up from start to finish and do some audio test?

I really appreciate the help.

Maximo du2uxh

Hi there. Sorry you’re having issues.

htpasswd is responsible for just the web login. If you manager login was incorrect, you should still be able to login via the web.

Would you mind sending me a tar gzip of /var/www/html/allmon2 and /etc/asterisk/manager.conf?


Hi Rob,

Thank you for the reply. How can I send this files to you? I tried to attached it here but I got an error saying the files are not supported as attachment. I tried sending to your email add but it’s blocked by gmail. Sorry.


Oops - sorry. Send them to

Moved to private message to resolve.

The [admin] stanza was below the include. I’ve updated the default manager.conf to look like this instead:

; Asterisk Call Management support

; By default asterisk will listen on localhost only.
enabled = yes
port = 5038
bindaddr =

secret = CHANGEME
read = all,system,call,log,verbose,command,agent,user,config
write = all,system,call,log,verbose,command,agent,user,config

Changed his allmon.ini.php to:



Thanks Rob. I followed your instructions and changed what needs to be changed and reboot the Pi. But I still have the same “Sorry, login failed” message. allstar_allmon


Hum. Try regenerating your password with the following commands:

cd /var/www/html/allmon2
rm .htpasswd && htpasswd -c .htpasswd admin

If this doesn’t work out for you, I’m happy to SSH into your node and help figure it out. Lmk if it doesn’t.


rm: cannot remove ‘…htpasswd’: No such file or directory. I am in /var/html/allmon2 directory.