Load Kernal Modules issue 2.02 beta

I continue trying to figure out why I get a first line error message on boot stating “Failed to start Load Kernal Modules”.
During setup for internet connection I established DHCP, but in troubleshooting I cannot ping Google or Allstar. During startup on my HP 8640p the wireless disconnect button goes from blue to red when boot starts (something is turning off my wireless and I cannot turn it back on). I tried hard wired LAN to the router. No dice.
When I enter setup for simple USB I get a message stating: SimpleUSB must be enabled in modules.conf and selected in rpt.conf.
When I go to edit both, they appear to be set up correctly. I’m guessing that my lack of connection to Allstar is the problem. Is there a fix to the this wireless disconnect issue? I thought maybe it’s a BIOS issue, but this computer has a locked BIOS and no password is known. HP won’t help me with it either, so no BIOS access. Allstar did establish DHCP during setup so it used to communicate.
As a diagnostic effort I loaded beta version 2.0. This version would not connect to my router so I re-installed 2.02 and it connected again (during setup that is. Wireless still drops at start of boot).
I appreciate any help.

Update: I ran dpkg-reconfigure asl-dahdi-linux-dkms. Failed to start boot error no longer seen along with the rest of the boot log. In systemctl the once “failed” line now reads “systemd-modules-load.service (loaded active) (exited)” is shown so I guess that’s fixed. Still no ping or wireless network. Still can’t setup simple USB.

Enabled simple USB in repeater config. and got test tones. Just need internet connection now. Suspect BIOS.

If you need to reset BIOS password, I’ve found instructions online before that involve disconnecting power, moving a jumper near the CMOS to a reset position, then applying power for X seconds, and moving the jumper back. Something like that but you would need the specific instructions for your manufacturer.

I find it highly strange that using wired Ethernet didn’t work. Do you at least get assigned an IP address (command is either “ifconfig” or “ip addr”)? Can you ping your network gateway? If it was just wifi that’s not working maybe look into rfkill to see if that is disabling it? Just some ideas.