First ASL Node - DTMF Questions

I’m new to ASL but have had a new node up and running for a while now connected to an Alinco DR-135 MkIII radio, a URI-B interface, and appropriate cables. I use it with two different brand HTs and with the Transceive App on my MacBook Pro computer. All of the basic functions seem to work such as linking/unlinking/taking/listening, etc. However, DTMF functions from the HTs or Transceive do not seem to have any effect.

SimpleUSB is used with volume settings usually set in the 800 range for receive and transmit. I have done my homework on DTMF reading/guidance but not completely sure if DTMF has to be manually enabled somewhere or if we have an audio issue. QSOs done through Transceive and the HTs receive good reports for audio quality and level…so perhaps audio is okay?

Any suggestions as to how to resolve this? Thank you.

So I’m trying to accomplish “one miracle per day” by getting DTMF to work. :slight_smile:

The only setting to turn on/off any dtmf that I am aware of are these, Not really turn off dtmf though.
but don’t pay much attention to the command number as they are not likely the defaults anymore,
Look at them in your file by cop# to see the actual setting in your rpt.conf file.

924=cop,17; User functions enable (time, id, etc)|

925=cop,18; User functions disable|

And then you can have control states but I doubt you have changed anything there from default.

Your problem is most likely audio levels not correct on the rx side. Even if your ouput sounds right.
You must adjust the rx to the correct levels before setting output or you are chasing your own tail.

You can watch asterisk live for decoding…
asterisk -rvvv
‘exit’ when done and return to command line.
But Simpleusb/radiousb ‘tune’ function is in the wiki.

Mike, Thank you for your reply.

Update: I can control my link via the Transceive App (MacBook). So the problem is DTMF via the HTs.

When using the ASL Asterisk CLI, I can see the decoding that is being triggered by the Transceive App DTMF commands.

When I attempt to use sudo asterisk -rvvv (with or without sudo), I get this error:

Connected to Asterisk GIT Version adaec47 currently running on repeater (pid = 503)
Verbosity was 0 and is now 3

repeater*CLI> sudo asterisk -rvvv
No such command ‘sudo asterisk -rvvv’ (type ‘help sudo asterisk’ for other possible commands)

repeater*CLI> help sudo asterisk
No such command ‘sudo asterisk’.

repeaterCLI> asterisk -rvvv
No such command ‘asterisk -rvvv’ (type ‘help asterisk -rvvv’ for other possible commands)

'Not sure what’s up with that.

When using Option 4, Run “simpleusb-tune-menu for SimpleUSB configuration”, then click 2 to “Set Rx Voice Level (using display)” I do not see any on-screen volume levels when I key-up with the HT and talk.

I have been very careful to save changes and restart Asterisk after changes.

So a little progress but still issues. Thank you.


DTMF working from HTs now. The root cause was that the simpleusb.conf had some incorrect settings which precluded the volume adjustment from appearing on screen.

Still not sure why the “asterisk -rvvv” command doesn’t work.

Thank you. again. I will post my simpleusb.conf file here for others to benefit.


It did work, but you can’t run it again inside itself LOL

When you see this
Connected to Asterisk GIT Version adaec47 currently running on repeater (pid = 503)
Verbosity was 0 and is now 3

and then this


You are looking at asterisk command line and asterisk output in the foreground, not a bash shell line anymore. When you want to exit the asterisk ‘CLI’ type exit and be back to bash shell.

And if you watch that ‘CLI’ screen while inputting dtmf, you will see what it is dtmf decoding live. If any as well as other things that show under verbosity of 3. The more v’s the more verbosity up to 5
asterisk -rvvvvv but use 3 for most everything. I think some things do not show under higher V’s for some reason.