Errors in uhandler up on stats.allstarlink and node registered but not in database

Every time I ping stats.allstarlink.org from my server, I keep getting this error returned:
[Oct 6 21:27:58] ERROR[28824]: app_rpt.c:5250 rpt_event_process: event exec item malformed: /usr/bin/wget,-q,–timeout=15,–tries=1,–output-document=/dev/null
[Oct 6 21:27:58] ERROR[28824]: app_rpt.c:5250 rpt_event_process: event exec item malformed: http://stats.allstarlink.org/uhandler.php

This is on the latest code base (I finally FINALLY upgraded from ACID and brought my 220 node and hub back online), and the line seems to be the same as it was in acid, so, just wondering…

On another note, I see that my node 27294 is registered when I do an iax2 show registry:

44.98.254.145:4569 Y 27294 xx.xx.xx.xx:4569 60 Registered

but it’s not showing up in the database (ie the bubble chart shows it in pink), but I can connect to it and it’s repeating.

Are there any issues with the head end? Just wondering if these are related, or two separate issues or it’s an ID 10-T error.

Thanks es 73
bryan
27294 and a whole bunch of other nodes
morrisville PA/Fall River MA

Hi Bryan,

We’ve had someone else with this error before. Please see this post


His problem mysteriously went away but maybe you could try some of these same troubleshooting steps.

The not showing up in the database could be caused if the statspost line in rpt.conf is incorrect or commented.

Any of that help?

Nada. Still pink on bubble chart, 27294 shows registered (as do my other 2 nodes on the system):
Host dnsmgr Username Perceived Refresh State
44.98.254.145:4569 Y 27673 x.x.x.x:4569 60 Registered
44.98.254.145:4569 Y 27295 x.x.x.x:4569 60 Registered
44.98.254.145:4569 Y 27294 x.x.x.x:4569 60 Registered

Can ping stats server. but the registration is not making it into the database somehow. And that’s nothing I can debug from here.

Please take a look at your /etc/asterisk/rpt.conf and ensure you have the statpost_program listed in each of the nodes stanzas

ie:

[27294]
rxchannel =
idtalkover =
statpost_program =
stapost_url =

[27295]
rxchannel =
idtalkover =
statpost_program =
statpost_url =

All three nodes have the same:

statpost_program = /usr/bin/wget,-q,–timeout=15,–tries=1,–output-document=/dev/null
statpost_url = http://stats.allstarlink.org/uhandler.php

27295 and 27673 all report properly.

Is 27294 new to this server?

not since 2010…:slight_smile:

1 Like

Is it also listed in the [nodes] stanza ? For nodes on that instance.

Thank you
Nathan Hardman
Nhardman1428@gmail.com

···

On Oct 10, 2019, at 5:43 PM, Bryan D. Boyle via AllStarLink Discussion Groups noreply@community.allstarlink.org wrote:

Bryan_D_Boyle
Bryan_D_Boyle

    October 10

not since 2010…:slight_smile:


Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.

Everything lines up;
it can connect to the outside world, iax2 show registry shows that it’s registered with the home ship:
44.98.254.145:4569 Y 27673 x.x.x.x:4569 60 Registered
44.98.254.145:4569 Y 27295 x.x.x.x:4569 60 Registered
44.98.254.145:4569 Y 27294 x.x.x.x:4569 60 Registered

the other two nodes (using the same exact statpost lines) on that server are registering in the database, the []nodes] stanza has:

27294 = radio@127.0.0.1:4569/27294,NONE
27295 = radio@127.0.0.1:4569/27295,NONE
27673 = radio@127.0.0.1:4569/27673,NONE

under the node list at https://web-tpa.allstarlink.org/nodelist/ searching for wb0yle, it shows up as green, but the bubble chart still shows as not in database.

Not a critical error, I am thinking, just frustrating to sort it out…

Sorry you are having so much trouble with this. Don’t feel bad, it’s common to have this problem.

The stats server was reset last night (because it was completely down) so as much as I hate to say this, I don’t know how it can be on the server side.

Would you like me to logon to you node look around? We can start a private message to exchange info if you want to do that.

According to the log files on the server. Node 27294 is not sending any status updates to the server. Nodes 27295 and 27673 have plenty.

···

Nathan Hardman

nhardman1428@gmail.com

N8THN@ARRL.NET