Continual connect/hangup behaviour cycle

I have observed some two curious behaviours that I am wondering if someone might understand better than me and explain:

  1. I run multiple nodes. Sometimes I try to connect to another node (not one of mine) and I get “connection failed.” I try from another one of my nodes and it works. The behaviour is not consistent in that it always fails on node A and always works on node B. Perhaps related, sometimes Node A fails to connect and 20 seconds (or so) later I try again and it does connect.

  2. Sometimes I can connect to a node without issue (just to confirm it is up and running and accepting connections). Then I disconnect and try connecting to it from another node and that node goes into an infinite loop cycle where the CLI shows “connected, format is ulaw, etc” and then immediately hangs up. The supermon panel shows continual attempt “Connecting OUT” but never resolves to a connected state.

Thx. Adrian VE7NZ

I discovered the problem was that I had a register= line in iax.conf for the same node at another IP address in my network. This meant the node number was being registered to whichever node last cycled a registration request. That’s why sometimes it worked, sometimes it didn’t.

User error!


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.