Architecture not supported

Trying to install on a Dell E6420 laptop here, using a DVD made from a download of ASL1.01 that I made a few weeks ago.

It gets most of the way through the install to the point where it wants to configure apt repositories. Then it stops with an “architecture not supported” message and invites me to specify a different mirror site for the Debian repository. None of the ones I tried worked either. The Dell laptop is not a strange architecture. Is there something in the install routine that is now out of date? What could be the problem?


ASL 1.01 had a rough time over the years and I’m not sure that all of the scars have been healed. You’ll likely have better luck installing and using the beta from the Downloads section of the WiKi (

I did one of these on a different machine a few weeks ago and it is working fine. The reason I chose 1.01 was that the Beta was throwing seg-faults and would not run Broadcastify. See my other postings. Sigh.
BTW - a friend of mine has got 1.01 to run on his E6420. Not sure why his worked and mine didn’t.

The segfaults are from stats reporting. It core dumps each time a status is posted. They are annoying but harmless.

I should also mention that we are not having good results trying to write an ISO to a USB stick with Etcher. I note that the wiki shows an IMG file not an ISO format.

1 Like