AllStar node with duplex=0 not identifying itself: how to correct

I am using an AllStar node as a link to a repeater. After much experimentation duplex needs to be zero to keep from oscillating between the repeater and the link so rpt.conf is set to":

; duplex=0 - Half duplex with no telemetry
; tones or hang time. Special Case: Full
; duplex if linktolink is set to yes.
; This mode is preferred when interfacing
; with an external multiport repeater controller.


Echolink announcement is set to 2:

; Echolink announcement mode
; Default: 1 = Say only node number on echolink
; connects. 2 = say phonetic call sign only on
; echolink connects. 3 = say phonetic call sign
; and node number on echolink connects

and id settings is set to:

idrecording=|iDE AB1PH/R

But the node never identifies itself.

Any thoughts?

I am not sure that it is legal for the node to never identify itself.


No Telemetry does mean no telemetry.
I believe in origin, this was intended for a direct wire link where radio ID was not required.
I remember interfacing to a port on a link port switch of a cat1000 controller 13 years ago and with wire, it was not a issue.

There are probably other ways of achieving what it is you are making with a radio link in different config but I can’t advise on what I do not know what you are doing and exactly how you are doing it…

A simple fix would be to schedule a id in time interval you want using scheduler and macro.
But there is no provision for a machine in ‘sleep mode’ and would id all the time.
However a simple script looking at sleep state, then id would be the ultimate cure.

Looking at IRLP and others it seems this is not an unusual situation. Use of a radio link over a wire link is a trivial chance and clearly the duplex mode supports this.

I am unsure what I need to do to ex[plain what I am going.

I have a small transceiver running AllStar with echoolink configured.

It receives voice over the internet and transmits on the repeater input frequency of in this case 146.295 with the PL tone of 123.0.

It receives from the repeater on 146.895 and sends the voice out ofver the internet.

It needs to be in half duplex to avoid communications cycling with the repeater, and it looks like only duplex=0 supports that.

I am unsure how one would create these scripts. Are there examples of documentation?


OK I did some more experimenting to confirm earlier testing.

If I set duplex to 1, I do get simplex communications AND I have gotten telemetry in the past.

And it works great for a simplex station.

If I am on a repeaters, then after transmission from the AllStar node, the AllStar node receives the repeater tail and sends a transmission to the repeater. The repeater sent the transmission tail and the cycle repeats. So dup[lex=1 does not seem to work properly for repeaters.

But duplex=0 does not identify.

So it seems a bit of a quandary.

Any thoughts?


Ok the magic elixir seems to be:


nounkeyct=1. (no courtesy tone)

This seems to stop the flip flopping of the repeater.

1 Like

Well, you answered yourself before I got the chance…
Good Job thinking it through…LOL…
I would imagine you still need linktolink set in that mode. Just a note for others reading late.

There are other methods yet to do similar.

1 Like

Duplex =0

you do not want to send anything over echolink as it would be frowned upon. here are my settings and they work like a champ. you only get the announcements when connection is made or dropped at the local end.

That brings back his original issue of no id on rf link.

you do not want ID on an RF link. you want the ID on a repeater locally.

What part in the FCC rules allows that ?

On the question of a node operation on a repeater input (ie as a repeater user). For clarification this usage is not an AllStar link. AllStar links are half or full duplex VoIP channels with no repeat loop at either end. There are no courtesy tones or IDs, just audio.

The ping pong issue discussed here is solvable but there are other considerations. These may include automatic IDs on the repeater input, courtesy tones and repeater IDs sent to connected nodes and degraded audio.

The courtesy tones and IDs from the repeater can be muted (for the most part) if the repeater does not send CTCSS during those events and the node is in CTCSS decode. However, if the repeater IDs or there is a courtesy tone while someone is talking it will be heard on the link. But at least these won’t key up the link.

One of the beautiful things about AllStar is the great audio. This happens in part because there are no additional radios no matter how many links (AllStar connections) are involved. So you always get repeater path audio and noting more. This is why AllStar users sound like they are on the same repeater as you are.

The best way to use AllStar on your repeater is to connect it to a port on your existing controller, or better yet, replace the controller with AllStar. AllStar is the best repeater controller there is and the software is free. Yeah, expense and effort is required to make such a big change but it’s well worth it.

3 posts were split to a new topic: Getting Echo at end of Transmission